summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 03:59:11 +0100
committerSam James <sam@gentoo.org>2021-04-07 06:24:26 +0100
commit2c6d7eb8057ca361a82f0159609f137855c7e706 (patch)
treeca74e4fb4252bfe7719c28180d476b5c69b7a0f2 /sys-apps/linux-misc-apps
parentsci-libs/mumps: prefix helper get_version_component_count with _ (diff)
downloadgentoo-2c6d7eb8057ca361a82f0159609f137855c7e706.tar.gz
gentoo-2c6d7eb8057ca361a82f0159609f137855c7e706.tar.bz2
gentoo-2c6d7eb8057ca361a82f0159609f137855c7e706.zip
sys-apps/linux-misc-apps: prefix helper get_version_component_count with _
Avoids false positives with pkgcheck's MissingInherits. This is a helper function to emulate versionator.eclass, it's not a missing inherit. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/linux-misc-apps')
-rw-r--r--sys-apps/linux-misc-apps/linux-misc-apps-5.8.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-apps/linux-misc-apps/linux-misc-apps-5.8.ebuild b/sys-apps/linux-misc-apps/linux-misc-apps-5.8.ebuild
index 7b479642bd76..305b9ee03e9a 100644
--- a/sys-apps/linux-misc-apps/linux-misc-apps-5.8.ebuild
+++ b/sys-apps/linux-misc-apps/linux-misc-apps-5.8.ebuild
@@ -18,7 +18,7 @@ MY_PV="${MY_PV/-pre/-git}"
LINUX_V=$(ver_cut 1-2)
-get_version_component_count() {
+_get_version_component_count() {
local cnt=( $(ver_rs 1- ' ') )
echo ${#cnt[@]} || die
}
@@ -29,7 +29,7 @@ if [ ${PV/_rc} != ${PV} ]; then
LINUX_PATCH=patch-${PV//_/-}.xz
SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/testing/${LINUX_PATCH}
https://www.kernel.org/pub/linux/kernel/v3.x/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [ $(get_version_component_count) == 4 ]; then
+elif [ $(_get_version_component_count) == 4 ]; then
# stable-release series
LINUX_VER=$(ver_cut 1-3)
LINUX_PATCH=patch-${PV}.xz