summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-09-19 09:59:47 +0200
committerUlrich Müller <ulm@gentoo.org>2022-09-19 10:03:45 +0200
commit965ccb2d69c3a70ead6b7fae55588c8eb3826507 (patch)
treeb77305836ef5ffef51766917477b44365c3c7b75 /sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild
parentRevert "sys-apps/man-pages-posix: drop 2013a (EAPI 5)" (diff)
downloadgentoo-965ccb2d69c3a70ead6b7fae55588c8eb3826507.tar.gz
gentoo-965ccb2d69c3a70ead6b7fae55588c8eb3826507.tar.bz2
gentoo-965ccb2d69c3a70ead6b7fae55588c8eb3826507.zip
sys-apps/man-pages-posix: Update LICENSE to freedist
For what we know at this point in time, version 2017a of this package is nonfree because modification is not allowed. This is pending further clarification in bug 871636. Note that Fedora has dropped this package: https://bugzilla.redhat.com/show_bug.cgi?id=2116859 Bug: https://bugs.gentoo.org/871636 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild')
-rw-r--r--sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild b/sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild
new file mode 100644
index 000000000000..2fc43800f7ef
--- /dev/null
+++ b/sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-${PV:0:4}-${PV:0-1}"
+DESCRIPTION="POSIX man-pages (0p, 1p, 3p)"
+HOMEPAGE="https://www.kernel.org/doc/man-pages/"
+SRC_URI="https://www.kernel.org/pub/linux/docs/man-pages/${PN}/${MY_P}.tar.xz"
+
+LICENSE="freedist" # to be clarified, see bug 871636
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE=""
+RESTRICT="binchecks"
+
+RDEPEND="virtual/man !<sys-apps/man-pages-3"
+
+S="${WORKDIR}/${PN}-${PV:0:4}"
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ emake install DESTDIR="${ED}"
+ dodoc man-pages-*.Announce README
+}