summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-17 22:55:26 +0100
committerSam James <sam@gentoo.org>2023-07-17 22:55:26 +0100
commit9e35749eaf007ed8543c6c3eb8eb7ac11e207a7d (patch)
tree94c04ba789e1d93e1ece06fb324c866433da3afb /sys-apps/pv
parentnet-nds/openldap: add 2.6.5 (diff)
downloadgentoo-9e35749eaf007ed8543c6c3eb8eb7ac11e207a7d.tar.gz
gentoo-9e35749eaf007ed8543c6c3eb8eb7ac11e207a7d.tar.bz2
gentoo-9e35749eaf007ed8543c6c3eb8eb7ac11e207a7d.zip
sys-apps/pv: add 1.7.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/pv')
-rw-r--r--sys-apps/pv/Manifest1
-rw-r--r--sys-apps/pv/pv-1.7.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/pv/Manifest b/sys-apps/pv/Manifest
index 57d6f41631aa..1e63935c250e 100644
--- a/sys-apps/pv/Manifest
+++ b/sys-apps/pv/Manifest
@@ -1 +1,2 @@
DIST pv-1.6.20.tar.bz2 115310 BLAKE2B b50623f623231e8e8615f960bad83d10e12d5274c57d23ea843d16fce30b3e690284b2d9b01f82a16b9790e2bf26f80f560e226589a62ca677a2cf90ea007691 SHA512 e445f91b298ed285ddab54a3f8a6b5d5297e2e2eb8ad7b2ee2cbacca4adda9c6ca2bf3c77bf2a93373d3875c5b3b0b345d3945cbd91fc2647c6c25f1661a6752
+DIST pv-1.7.0.tar.bz2 115665 BLAKE2B efdd0434d23fe1ed008224fe0fe5182684010a78650284e920b2cd93134f08e63172df0279b8a4b2c2c4dceb9dbdaa209e402394fb1c4c431d991225f579f718 SHA512 b90ddaa1f950b1b300f1721e5ab8bc2c7a0c46491e439ce33c7b74fd4525e730a99c218a874b3dae2dc3a8a5e0eb5c5add51f7c8be48d0c3d8f135df44779af8
diff --git a/sys-apps/pv/pv-1.7.0.ebuild b/sys-apps/pv/pv-1.7.0.ebuild
new file mode 100644
index 000000000000..d13550cbb754
--- /dev/null
+++ b/sys-apps/pv/pv-1.7.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="de fr pl pt"
+PLOCALE_BACKUP="en"
+inherit flag-o-matic linux-info toolchain-funcs plocale
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="https://www.ivarch.com/programs/pv.shtml"
+SRC_URI="https://www.ivarch.com/programs/sources/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug nls"
+
+DOCS=( README.md doc/NEWS.md doc/TODO.md )
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ stat64 # See https://github.com/a-j-wood/pv/issues/69
+)
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~SYSVIPC"
+ ERROR_SYSVIPC="You will need to enable CONFIG_SYSVIPC in your kernel to use the --remote option."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+
+ sed -i -e 's:usleep 200000 || ::g' tests/019-remote-cksum || die
+
+ disable_locale() {
+ local locale=${1}
+ sed -i configure -e "/ALL_LINGUAS=/s:${locale}::g" || die
+ }
+
+ plocale_find_changes src/nls '' '.po'
+ plocale_for_each_disabled_locale disable_locale
+}
+
+src_configure() {
+ tc-export AR
+
+ # Workaround for https://github.com/a-j-wood/pv/issues/69
+ append-lfs-flags
+
+ econf \
+ --enable-lfs \
+ $(use_enable debug debugging) \
+ $(use_enable nls)
+}