summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-04-03 18:40:43 +0100
committerMarek Szuba <marecki@gentoo.org>2024-04-03 18:41:23 +0100
commit9759e6bec90d5b6ea839e3e4c0bf2a20bc595896 (patch)
tree792e53df08dc4da726c95a433016a2d68da941ff /sys-apps/the_silver_searcher
parentsys-apps/the_silver_searcher: phase out LFS64 interfaces (diff)
downloadgentoo-9759e6bec90d5b6ea839e3e4c0bf2a20bc595896.tar.gz
gentoo-9759e6bec90d5b6ea839e3e4c0bf2a20bc595896.tar.bz2
gentoo-9759e6bec90d5b6ea839e3e4c0bf2a20bc595896.zip
sys-apps/the_silver_searcher: drop 2.2.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-apps/the_silver_searcher')
-rw-r--r--sys-apps/the_silver_searcher/Manifest1
-rw-r--r--sys-apps/the_silver_searcher/files/the_silver_searcher-fno-common.patch164
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-2.2.0.ebuild54
3 files changed, 0 insertions, 219 deletions
diff --git a/sys-apps/the_silver_searcher/Manifest b/sys-apps/the_silver_searcher/Manifest
index d0b5e63ea97a..0623405bb37c 100644
--- a/sys-apps/the_silver_searcher/Manifest
+++ b/sys-apps/the_silver_searcher/Manifest
@@ -1,2 +1 @@
-DIST the_silver_searcher-2.2.0.tar.gz 163686 BLAKE2B ca81f701336ff463b6dc783ac8bc615a05e048c35b653a80c3fb74b053bb71f4822990b699a9e3741c7ffdd2581b65faa5439824189a9d8e36025d248201f814 SHA512 b635165fa3259475027986dd49c0786545cc2e3037695aec70f6ee54eaa768ab0e25af78d4bfd3754c4eb8352464cebf64324ed4a68a4b3de60a6889473da26e
DIST the_silver_searcher-2.2.0_p20201217.tar.gz 165236 BLAKE2B eaf5e657b33d463048a83e08a90588448cb2fcd481b1f7f869e82c5e1ae1168a10dacb0d549dcc4acafb4323c96a9b67ff9e58de85f80bd2bd7e209ddc5ca6fa SHA512 96bc8da8ba10034bbb646bac71d479a21a68793e8af5377481da72c8dfa49ac99a1540c2b4193c4a95167127f1caa48fbd611ba367b8279bd2115549b6d8d126
diff --git a/sys-apps/the_silver_searcher/files/the_silver_searcher-fno-common.patch b/sys-apps/the_silver_searcher/files/the_silver_searcher-fno-common.patch
deleted file mode 100644
index 49861018e3ad..000000000000
--- a/sys-apps/the_silver_searcher/files/the_silver_searcher-fno-common.patch
+++ /dev/null
@@ -1,164 +0,0 @@
---- a/src/search.h
-+++ b/src/search.h
-@@ -31,9 +31,9 @@
- #include "uthash.h"
- #include "util.h"
-
--size_t alpha_skip_lookup[256];
--size_t *find_skip_lookup;
--uint8_t h_table[H_SIZE] __attribute__((aligned(64)));
-+extern size_t alpha_skip_lookup[256];
-+extern size_t *find_skip_lookup;
-+extern uint8_t h_table[H_SIZE] __attribute__((aligned(64)));
-
- struct work_queue_t {
- char *path;
-@@ -41,12 +41,12 @@
- };
- typedef struct work_queue_t work_queue_t;
-
--work_queue_t *work_queue;
--work_queue_t *work_queue_tail;
--int done_adding_files;
--pthread_cond_t files_ready;
--pthread_mutex_t stats_mtx;
--pthread_mutex_t work_queue_mtx;
-+extern work_queue_t *work_queue;
-+extern work_queue_t *work_queue_tail;
-+extern int done_adding_files;
-+extern pthread_cond_t files_ready;
-+extern pthread_mutex_t stats_mtx;
-+extern pthread_mutex_t work_queue_mtx;
-
-
- /* For symlink loop detection */
-@@ -64,7 +64,7 @@
- UT_hash_handle hh;
- } symdir_t;
-
--symdir_t *symhash;
-+extern symdir_t *symhash;
-
- void search_buf(const char *buf, const size_t buf_len,
- const char *dir_full_path);
---- a/src/search.c
-+++ b/src/search.c
-@@ -2,6 +2,19 @@
- #include "print.h"
- #include "scandir.h"
-
-+ size_t alpha_skip_lookup[256];
-+ size_t *find_skip_lookup;
-+ uint8_t h_table[H_SIZE] __attribute__((aligned(64)));
-+
-+ work_queue_t *work_queue;
-+ work_queue_t *work_queue_tail;
-+ int done_adding_files;
-+ pthread_cond_t files_ready;
-+ pthread_mutex_t stats_mtx;
-+ pthread_mutex_t work_queue_mtx;
-+
-+ symdir_t *symhash;
-+
- void search_buf(const char *buf, const size_t buf_len,
- const char *dir_full_path) {
- int binary = -1; /* 1 = yes, 0 = no, -1 = don't know */
---- a/src/log.c
-+++ b/src/log.c
-@@ -4,6 +4,8 @@
- #include "log.h"
- #include "util.h"
-
-+pthread_mutex_t print_mtx;
-+
- static enum log_level log_threshold = LOG_LEVEL_ERR;
-
- void set_log_level(enum log_level threshold) {
---- a/src/log.h
-+++ b/src/log.h
-@@ -9,7 +9,7 @@
- #include <pthread.h>
- #endif
-
--pthread_mutex_t print_mtx;
-+extern pthread_mutex_t print_mtx;
-
- enum log_level {
- LOG_LEVEL_DEBUG = 10,
---- a/src/options.h
-+++ b/src/options.h
-@@ -91,7 +91,7 @@
- } cli_options;
-
- /* global options. parse_options gives it sane values, everything else reads from it */
--cli_options opts;
-+extern cli_options opts;
-
- typedef struct option option_t;
-
---- a/src/options.c
-+++ b/src/options.c
-@@ -16,6 +16,8 @@
- #include "print.h"
- #include "util.h"
-
-+cli_options opts;
-+
- const char *color_line_number = "\033[1;33m"; /* bold yellow */
- const char *color_match = "\033[30;43m"; /* black with yellow background */
- const char *color_path = "\033[1;32m"; /* bold green */
---- a/src/util.h
-+++ b/src/util.h
-@@ -12,7 +12,7 @@
- #include "log.h"
- #include "options.h"
-
--FILE *out_fd;
-+extern FILE *out_fd;
-
- #ifndef TRUE
- #define TRUE 1
-@@ -51,7 +51,7 @@
- } ag_stats;
-
-
--ag_stats stats;
-+extern ag_stats stats;
-
- /* Union to translate between chars and words without violating strict aliasing */
- typedef union {
---- a/src/util.c
-+++ b/src/util.c
-@@ -15,6 +15,10 @@
- #define getc_unlocked(x) getc(x)
- #endif
-
-+FILE *out_fd;
-+
-+ag_stats stats;
-+
- #define CHECK_AND_RETURN(ptr) \
- if (ptr == NULL) { \
- die("Memory allocation failed."); \
---- a/src/ignore.c
-+++ b/src/ignore.c
-@@ -22,6 +22,8 @@
-
- /* TODO: build a huge-ass list of files we want to ignore by default (build cache stuff, pyc files, etc) */
-
-+ignores *root_ignores;
-+
- const char *evil_hardcoded_ignore_files[] = {
- ".",
- "..",
---- a/src/ignore.h
-+++ b/src/ignore.h
-@@ -29,7 +29,7 @@
- };
- typedef struct ignores ignores;
-
--ignores *root_ignores;
-+extern ignores *root_ignores;
-
- extern const char *evil_hardcoded_ignore_files[];
- extern const char *ignore_pattern_files[];
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-2.2.0.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-2.2.0.ebuild
deleted file mode 100644
index 5b4b3e89acdc..000000000000
--- a/sys-apps/the_silver_searcher/the_silver_searcher-2.2.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools bash-completion-r1
-
-DESCRIPTION="A code-searching tool similar to ack, but faster"
-HOMEPAGE="https://github.com/ggreer/the_silver_searcher"
-SRC_URI="https://github.com/ggreer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 x86 ~amd64-linux"
-IUSE="lzma test zlib"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-libs/libpcre
- lzma? ( app-arch/xz-utils )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? (
- dev-util/cram
- dev-vcs/git
- )"
-
-DOCS="README.md"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.0-lzma.patch
- "${FILESDIR}"/${PN}-fno-common.patch
-)
-
-src_prepare() {
- sed '/^dist_bashcomp/d' -i Makefile.am || die
-
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable lzma) \
- $(use_enable zlib)
-}
-
-src_test() {
- cram -v tests/*.t || die "tests failed"
-}
-
-src_install() {
- default
- newbashcomp ag.bashcomp.sh ag
-}