summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-05 03:14:49 +0100
committerSam James <sam@gentoo.org>2024-08-05 03:16:01 +0100
commit57bb72792b70a1fed1dcdea4f3345c7e049d51e1 (patch)
tree25706bf53834388bde1cd22a1320d9bfe6a574af /sys-apps
parentsci-mathematics/dunshire: don't use setup.py for tests (diff)
downloadgentoo-57bb72792b70a1fed1dcdea4f3345c7e049d51e1.tar.gz
gentoo-57bb72792b70a1fed1dcdea4f3345c7e049d51e1.tar.bz2
gentoo-57bb72792b70a1fed1dcdea4f3345c7e049d51e1.zip
sys-apps/gentoo-functions: fix 1.7 ebuild to be based upon 9999
Kerin rightly points out I used the wrong template. I never normally get that wrong :( Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-1.7-r1.ebuild (renamed from sys-apps/gentoo-functions/gentoo-functions-1.7.ebuild)26
1 files changed, 21 insertions, 5 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-1.7.ebuild b/sys-apps/gentoo-functions/gentoo-functions-1.7-r1.ebuild
index 8df3a1e88bad..864663a97757 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-1.7.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-1.7-r1.ebuild
@@ -3,6 +3,11 @@
EAPI=8
+inherit meson
+
+DESCRIPTION="Base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
@@ -11,11 +16,6 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
fi
-inherit meson
-
-DESCRIPTION="Base functions required by all Gentoo systems"
-HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
-
LICENSE="GPL-2 public-domain"
SLOT="0"
IUSE="test"
@@ -34,3 +34,19 @@ src_configure() {
meson_src_configure
}
+
+src_install() {
+ meson_src_install
+
+ if [[ ${EPREFIX} ]]; then
+ while read -r; do
+ if [[ ${REPLY} == $'\t'genfun_prefix= ]]; then
+ printf 'genfun_prefix=%q\n' "${EPREFIX}"
+ else
+ printf '%s\n' "${REPLY}"
+ fi || ! break
+ done < "${ED}/lib/gentoo/functions.sh" > "${T}/functions.sh" \
+ && mv -- "${T}/functions.sh" "${ED}/lib/gentoo/functions.sh" \
+ || die
+ fi
+}