summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-04-24 22:11:04 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-04-24 22:11:04 +0200
commit7b0f5202b40b4eae53ead41d333531fd30033e9c (patch)
tree0d20d6a271d695ab6ee258291ccfecca4f26f2e2 /sys-boot/syslinux/syslinux-6.03.ebuild
parentnet-analyzer/rrdtool: set SONAME based sub-SLOT (bug #580964 by Thomas D.). (diff)
downloadgentoo-7b0f5202b40b4eae53ead41d333531fd30033e9c.tar.gz
gentoo-7b0f5202b40b4eae53ead41d333531fd30033e9c.tar.bz2
gentoo-7b0f5202b40b4eae53ead41d333531fd30033e9c.zip
sys-boot/syslinux: bump to latest prerelase, add workaround for ld.gold issues.
Bug: https://bugs.gentoo.org/show_bug.cgi?id=563364 Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-boot/syslinux/syslinux-6.03.ebuild')
-rw-r--r--sys-boot/syslinux/syslinux-6.03.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sys-boot/syslinux/syslinux-6.03.ebuild b/sys-boot/syslinux/syslinux-6.03.ebuild
index 25ec57bc1fc1..fe34dc6eb086 100644
--- a/sys-boot/syslinux/syslinux-6.03.ebuild
+++ b/sys-boot/syslinux/syslinux-6.03.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -72,6 +72,17 @@ src_prepare() {
x86) loaderarch="efi32" ;;
*) ewarn "Unsupported architecture, building installers only." ;;
esac
+
+ # building with ld.gold causes problems, bug #563364
+ if tc-ld-is-gold; then
+ ewarn "Building syslinux with the gold linker may cause problems, see bug #563364"
+ if [[ -z "${I_KNOW_WHAT_I_AM_DOING}" ]]; then
+ tc-ld-disable-gold
+ ewarn "set I_KNOW_WHAT_I_AM_DOING=1 to override this."
+ else
+ ewarn "Continuing anyway as requested."
+ fi
+ fi
}
src_compile() {