summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBiosias <jakub@gdos.sk>2024-12-09 16:09:43 +0100
committerNowa Ammerlaan <nowa@gentoo.org>2024-12-09 17:50:18 +0100
commitbcd522c18db81f5c09e10fd27d7ee9af2d4fba03 (patch)
tree4836190c8f25d86fbc21a2ee4160c541950965ff /sys-boot/uefi-mkconfig
parentsys-boot/uefi-mkconfig: drop 3.2 (diff)
downloadgentoo-bcd522c18db81f5c09e10fd27d7ee9af2d4fba03.tar.gz
gentoo-bcd522c18db81f5c09e10fd27d7ee9af2d4fba03.tar.bz2
gentoo-bcd522c18db81f5c09e10fd27d7ee9af2d4fba03.zip
sys-boot/uefi-mkconfig: add 3.4
Signed-off-by: Biosias <jakub@gdos.sk> Closes: https://github.com/gentoo/gentoo/pull/39652 Signed-off-by: Nowa Ammerlaan <nowa@gentoo.org>
Diffstat (limited to 'sys-boot/uefi-mkconfig')
-rw-r--r--sys-boot/uefi-mkconfig/Manifest1
-rw-r--r--sys-boot/uefi-mkconfig/uefi-mkconfig-3.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-boot/uefi-mkconfig/Manifest b/sys-boot/uefi-mkconfig/Manifest
index 27d687dce4e1..daf33019dd62 100644
--- a/sys-boot/uefi-mkconfig/Manifest
+++ b/sys-boot/uefi-mkconfig/Manifest
@@ -1,2 +1,3 @@
DIST uefi-mkconfig-2.3.tar.gz 10295 BLAKE2B cae2301b1c181f87efbb47fbb393184ed383d763932999719223a298062cd802c318aeb9a1e4571483fe872b31ee27c86186a1200531d038e4ffe867ac683361 SHA512 730546552739db386249e0f86bce029ccb2695bd4b065326ae91ae92ab350ee387e46b661514b80728e609aa851a78efdda97a86fd7418c6f0044341c393c452
DIST uefi-mkconfig-3.3.tar.gz 14444 BLAKE2B 028562cf41ad4e936a60fad695ab9342f9c06f67e8ccb5afaaf72ad1d5cde3938e8b344d64c375b9468c61fb7074645c5f9ab6c8f351ed93215ae0b7d8d96143 SHA512 5a8236edffef7a3de8d463dcca1006bf54f3e86538d3fd797e49ec545056bab4d974b7e64fe9a37110c1cc671d4261197074cbcb35be0744e02a3742ebb8e398
+DIST uefi-mkconfig-3.4.tar.gz 14752 BLAKE2B bfe433937a233e07636c7d9a08ef91ce528ef3d8a2fcbdc045b135d632633236e9b9de9a0c913f301703da66375093868a6fb9630ccb187f6436fada663b7f32 SHA512 148304f8781cbdaf68845eb7db36d83881f653558d797cb8f288d2f8ae31e0f63f194972c6f4cb1b8f718e2d385cf34a4ddca2f41e92ac826631865910abfdb5
diff --git a/sys-boot/uefi-mkconfig/uefi-mkconfig-3.4.ebuild b/sys-boot/uefi-mkconfig/uefi-mkconfig-3.4.ebuild
new file mode 100644
index 000000000000..eb46eef391d5
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/uefi-mkconfig-3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info optfeature
+
+DESCRIPTION="Automatic management of UEFI entries"
+HOMEPAGE="https://github.com/Biosias/uefi-mkconfig"
+SRC_URI="https://github.com/Biosias/uefi-mkconfig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ app-shells/bash
+ sys-boot/efibootmgr
+"
+
+CONFIG_CHECK="~EFI_STUB"
+
+src_install() {
+ dobin uefi-mkconfig
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "uefi-mkconfig: Automatic management of UEFI entries"
+ elog "Run uefi-mkconfig while having all efi partitions mounted"
+ elog "Please use with care, this package was tested on a limited number of machines"
+ elog "Some problems may arise due to different implementations of UEFI"
+ elog "Don't forget to add kernel commands to the configuration file before using this package!"
+ elog
+ optfeature "Add UEFI entries on kernel installation " \ "sys-kernel/installkernel[-systemd,efistub]"
+}