summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-10-18 14:56:57 -0400
committerBen Kohler <bkohler@gentoo.org>2024-10-09 11:45:29 -0500
commit9b88a06bc6250e2e1401497991a5ae0ecda81e97 (patch)
tree54c1ac3934fa3f5122b3d3cfadd54cdeefdcfb88 /sys-boot
parentdev-ruby/unf: Stabilize 0.2.0 arm64, #940957 (diff)
downloadgentoo-9b88a06bc6250e2e1401497991a5ae0ecda81e97.tar.gz
gentoo-9b88a06bc6250e2e1401497991a5ae0ecda81e97.tar.bz2
gentoo-9b88a06bc6250e2e1401497991a5ae0ecda81e97.zip
sys-boot/syslinux: pass UPX=false to make
When building with bios support, Syslinux attempts to call upx. However, it is not a necessary build step and the build will just continue if it fails. This commit passes UPX=false to make when built with bios support to silence the command not found QA warnings. Closes: https://bugs.gentoo.org/888211 Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/33399 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild2
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild b/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
index cc03c3c95fd0..b13e8ee8582b 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
@@ -60,7 +60,7 @@ src_compile() {
unset CFLAGS LDFLAGS
if use bios; then
- emake bios DATE="${DATE}" HEXDATE="${HEXDATE}"
+ emake bios DATE="${DATE}" HEXDATE="${HEXDATE}" UPX=false
fi
if use uefi; then
if use abi_x86_32; then
diff --git a/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild b/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild
index 36ba918ffe7b..cc980c2f0157 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild
@@ -76,7 +76,7 @@ src_compile() {
unset CFLAGS LDFLAGS
if use bios; then
- emake bios DATE="${DATE}" HEXDATE="${HEXDATE}"
+ emake bios DATE="${DATE}" HEXDATE="${HEXDATE}" UPX=false
fi
if use uefi; then
if use abi_x86_32; then