summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-23 13:09:40 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-23 13:32:07 -0400
commitcdce4f74bbab176e7902127f0f0f98f45e922f17 (patch)
tree6d55065581e65d2679ec0b940bf336a4523a655c /sys-cluster
parentsys-cluster/openmpi: add 5.0.5 (diff)
downloadgentoo-cdce4f74bbab176e7902127f0f0f98f45e922f17.tar.gz
gentoo-cdce4f74bbab176e7902127f0f0f98f45e922f17.tar.bz2
gentoo-cdce4f74bbab176e7902127f0f0f98f45e922f17.zip
sys-cluster/prrte: new package, add 3.0.6
New dependency of openmpi which currently gets bundled instead. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/prrte/Manifest1
-rw-r--r--sys-cluster/prrte/metadata.xml11
-rw-r--r--sys-cluster/prrte/prrte-3.0.6.ebuild45
3 files changed, 57 insertions, 0 deletions
diff --git a/sys-cluster/prrte/Manifest b/sys-cluster/prrte/Manifest
new file mode 100644
index 000000000000..000d5865482f
--- /dev/null
+++ b/sys-cluster/prrte/Manifest
@@ -0,0 +1 @@
+DIST prrte-3.0.6.tar.gz 5976755 BLAKE2B 62cff51ebb7e72c32a237eb36db925f5bf5811cf5f409619128fa8ef490d3ba9e6ba4a1701edd21486878974088ff17645c98dab12904abd48c4a4b50453f807 SHA512 f7d3a1bedc0029fcb0e4e906a099d1de07b171805f0cc8d6e443826b8c321e3d5e7fa80867d8ab9ae1f628446a1a8f663231d8b67e243650582225805adc6e9d
diff --git a/sys-cluster/prrte/metadata.xml b/sys-cluster/prrte/metadata.xml
new file mode 100644
index 000000000000..51ef0c126080
--- /dev/null
+++ b/sys-cluster/prrte/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">openpmix/prrte</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-cluster/prrte/prrte-3.0.6.ebuild b/sys-cluster/prrte/prrte-3.0.6.ebuild
new file mode 100644
index 000000000000..00d73e624e1b
--- /dev/null
+++ b/sys-cluster/prrte/prrte-3.0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="PMIx Reference RunTime Environment"
+HOMEPAGE="https://openpmix.github.io/"
+SRC_URI="https://github.com/openpmix/prrte/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/libevent:=
+ sys-apps/hwloc:=
+ >=sys-cluster/pmix-4.2.4
+"
+RDEPEND="${DEPEND}"
+
+# There is no testsuite at least today.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ #
+ # Same issue as its companion project sys-cluster/pmix, and logically
+ # solvable in tandem (or never).
+ # https://github.com/openpmix/openpmix/issues/3350
+ filter-lto
+
+ econf
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}