summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-07 04:51:59 +0100
committerSam James <sam@gentoo.org>2022-04-07 04:57:23 +0100
commit7680e4a4a27eed792844a53761195e991473ecf7 (patch)
tree53362b4765dcc6796a126c014a2e429509f30e53 /sys-devel/make
parentsec-keys/openpgp-keys-m4: new package, add 20220407 (diff)
downloadgentoo-7680e4a4a27eed792844a53761195e991473ecf7.tar.gz
gentoo-7680e4a4a27eed792844a53761195e991473ecf7.tar.bz2
gentoo-7680e4a4a27eed792844a53761195e991473ecf7.zip
sys-devel/make: add verify-sig
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/make')
-rw-r--r--sys-devel/make/Manifest1
-rw-r--r--sys-devel/make/make-4.3.ebuild11
2 files changed, 9 insertions, 3 deletions
diff --git a/sys-devel/make/Manifest b/sys-devel/make/Manifest
index 34d9f6842b0f..f9cbb5a172f0 100644
--- a/sys-devel/make/Manifest
+++ b/sys-devel/make/Manifest
@@ -1 +1,2 @@
DIST make-4.3.tar.gz 2317073 BLAKE2B 5a82ce1f30eb034366ac3b87d2ec6698aae17d7b1a611941cf42136b2453b34236ab55382eab0a593c43cee8b036ba4a054f966c41ba766fdbd2862942be5dff SHA512 9a1185cc468368f4ec06478b1cfa343bf90b5cd7c92c0536567db0315b0ee909af53ecce3d44cfd93dd137dbca1ed13af5713e8663590c4fdd21ea635d78496b
+DIST make-4.3.tar.gz.sig 566 BLAKE2B 75bf71602e60f97ec8efa81676329047746d960257ef310b89a059144c00628b6a1ddf7a16a2ac2c3e935b8591475f5043a7c7546668ab39abbc4717c75a6528 SHA512 bf13e2943593b153457c8111179e8ae11cef2d9185a986106a1e70946a260bd930505a5e10002c5a60888e11affc07713c367b8680fd511ad87b2e124d303a99
diff --git a/sys-devel/make/make-4.3.ebuild b/sys-devel/make/make-4.3.ebuild
index bd0a3434e14e..e8c5f2009dca 100644
--- a/sys-devel/make/make-4.3.ebuild
+++ b/sys-devel/make/make-4.3.ebuild
@@ -1,24 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/make.asc
+inherit flag-o-matic verify-sig
DESCRIPTION="Standard tool to compile source trees"
HOMEPAGE="https://www.gnu.org/software/make/make.html"
if [[ "$(ver_cut 3)" -ge 90 ]] ; then
SRC_URI="https://alpha.gnu.org/gnu//make/${P}.tar.gz"
+ SRC_URI+=" verify-sig? ( https://alpha.gnu.org/gnu//make/${P}.tar.gz.sig )"
else
SRC_URI="mirror://gnu//make/${P}.tar.gz"
+ SRC_URI+=" verify-sig? ( mirror://gnu//make/${P}.tar.gz.sig )"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
+
LICENSE="GPL-3+"
SLOT="0"
IUSE="guile nls static"
DEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
-BDEPEND="nls? ( sys-devel/gettext )"
+BDEPEND="nls? ( sys-devel/gettext )
+ verify-sig? ( sec-keys/openpgp-keys-make )"
RDEPEND="${DEPEND}
nls? ( virtual/libintl )"