summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-19 05:05:19 +0000
committerSam James <sam@gentoo.org>2024-02-19 05:05:36 +0000
commit456eee6e374b50a4d9108a642ca29c5573ac5cb8 (patch)
treec71ce5871f18dc5e9c85aa940cbe170756cf9478 /sys-devel
parenttoolchain.eclass: rework fixincludes again (diff)
downloadgentoo-456eee6e374b50a4d9108a642ca29c5573ac5cb8.tar.gz
gentoo-456eee6e374b50a4d9108a642ca29c5573ac5cb8.tar.bz2
gentoo-456eee6e374b50a4d9108a642ca29c5573ac5cb8.zip
sys-devel/gcc: drop obsolete cross fixincludes patch for 13
We should be able to do this now after 0b75d3ce0bae8240c28c6a8f191f5130548f8475. Bug: https://bugs.gentoo.org/905118 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/files/gcc-13-fix-cross-fixincludes.patch19
-rw-r--r--sys-devel/gcc/gcc-13.2.1_p20230826.ebuild3
-rw-r--r--sys-devel/gcc/gcc-13.2.1_p20231216.ebuild3
-rw-r--r--sys-devel/gcc/gcc-13.2.1_p20240113-r1.ebuild1
-rw-r--r--sys-devel/gcc/gcc-13.2.1_p20240120.ebuild1
-rw-r--r--sys-devel/gcc/gcc-13.2.1_p20240127.ebuild1
-rw-r--r--sys-devel/gcc/gcc-13.2.1_p20240203.ebuild1
-rw-r--r--sys-devel/gcc/gcc-13.2.1_p20240210.ebuild1
-rw-r--r--sys-devel/gcc/gcc-13.2.1_p20240217.ebuild1
9 files changed, 2 insertions, 29 deletions
diff --git a/sys-devel/gcc/files/gcc-13-fix-cross-fixincludes.patch b/sys-devel/gcc/files/gcc-13-fix-cross-fixincludes.patch
deleted file mode 100644
index e4abe01a0830..000000000000
--- a/sys-devel/gcc/files/gcc-13-fix-cross-fixincludes.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Revert of https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=59e4c98173a79fcaa2c33253261409f38856c384
-for now to fix cross fixincludes builds.
-
-https://bugs.gentoo.org/905118
---- a/gcc/Makefile.in
-+++ b/gcc/Makefile.in
-@@ -532,11 +532,7 @@ LINKER_PLUGIN_API_H = $(srcdir)/../include/plugin-api.h
- # Default native SYSTEM_HEADER_DIR, to be overridden by targets.
- NATIVE_SYSTEM_HEADER_DIR = @NATIVE_SYSTEM_HEADER_DIR@
- # Default cross SYSTEM_HEADER_DIR, to be overridden by targets.
--ifeq (@includedir@,$(prefix)/include)
-- CROSS_SYSTEM_HEADER_DIR = @CROSS_SYSTEM_HEADER_DIR@
--else
-- CROSS_SYSTEM_HEADER_DIR = @includedir@
--endif
-+CROSS_SYSTEM_HEADER_DIR = @CROSS_SYSTEM_HEADER_DIR@
-
- # autoconf sets SYSTEM_HEADER_DIR to one of the above.
- # Purge it of unnecessary internal relative paths
diff --git a/sys-devel/gcc/gcc-13.2.1_p20230826.ebuild b/sys-devel/gcc/gcc-13.2.1_p20230826.ebuild
index b764492f9a87..55c73d734d7b 100644
--- a/sys-devel/gcc/gcc-13.2.1_p20230826.ebuild
+++ b/sys-devel/gcc/gcc-13.2.1_p20230826.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -60,6 +60,5 @@ src_prepare() {
toolchain_src_prepare
- eapply "${FILESDIR}"/${PN}-13-fix-cross-fixincludes.patch
eapply_user
}
diff --git a/sys-devel/gcc/gcc-13.2.1_p20231216.ebuild b/sys-devel/gcc/gcc-13.2.1_p20231216.ebuild
index a6c1746943ea..3032d482a760 100644
--- a/sys-devel/gcc/gcc-13.2.1_p20231216.ebuild
+++ b/sys-devel/gcc/gcc-13.2.1_p20231216.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -60,6 +60,5 @@ src_prepare() {
toolchain_src_prepare
- eapply "${FILESDIR}"/${PN}-13-fix-cross-fixincludes.patch
eapply_user
}
diff --git a/sys-devel/gcc/gcc-13.2.1_p20240113-r1.ebuild b/sys-devel/gcc/gcc-13.2.1_p20240113-r1.ebuild
index 7b1015f0e7cd..3404c76c9248 100644
--- a/sys-devel/gcc/gcc-13.2.1_p20240113-r1.ebuild
+++ b/sys-devel/gcc/gcc-13.2.1_p20240113-r1.ebuild
@@ -60,6 +60,5 @@ src_prepare() {
toolchain_src_prepare
- eapply "${FILESDIR}"/${PN}-13-fix-cross-fixincludes.patch
eapply_user
}
diff --git a/sys-devel/gcc/gcc-13.2.1_p20240120.ebuild b/sys-devel/gcc/gcc-13.2.1_p20240120.ebuild
index e295e327ec92..68348986bd19 100644
--- a/sys-devel/gcc/gcc-13.2.1_p20240120.ebuild
+++ b/sys-devel/gcc/gcc-13.2.1_p20240120.ebuild
@@ -60,6 +60,5 @@ src_prepare() {
toolchain_src_prepare
- eapply "${FILESDIR}"/${PN}-13-fix-cross-fixincludes.patch
eapply_user
}
diff --git a/sys-devel/gcc/gcc-13.2.1_p20240127.ebuild b/sys-devel/gcc/gcc-13.2.1_p20240127.ebuild
index e295e327ec92..68348986bd19 100644
--- a/sys-devel/gcc/gcc-13.2.1_p20240127.ebuild
+++ b/sys-devel/gcc/gcc-13.2.1_p20240127.ebuild
@@ -60,6 +60,5 @@ src_prepare() {
toolchain_src_prepare
- eapply "${FILESDIR}"/${PN}-13-fix-cross-fixincludes.patch
eapply_user
}
diff --git a/sys-devel/gcc/gcc-13.2.1_p20240203.ebuild b/sys-devel/gcc/gcc-13.2.1_p20240203.ebuild
index e295e327ec92..68348986bd19 100644
--- a/sys-devel/gcc/gcc-13.2.1_p20240203.ebuild
+++ b/sys-devel/gcc/gcc-13.2.1_p20240203.ebuild
@@ -60,6 +60,5 @@ src_prepare() {
toolchain_src_prepare
- eapply "${FILESDIR}"/${PN}-13-fix-cross-fixincludes.patch
eapply_user
}
diff --git a/sys-devel/gcc/gcc-13.2.1_p20240210.ebuild b/sys-devel/gcc/gcc-13.2.1_p20240210.ebuild
index aca4b7984086..e9961215dc32 100644
--- a/sys-devel/gcc/gcc-13.2.1_p20240210.ebuild
+++ b/sys-devel/gcc/gcc-13.2.1_p20240210.ebuild
@@ -60,6 +60,5 @@ src_prepare() {
toolchain_src_prepare
- eapply "${FILESDIR}"/${PN}-13-fix-cross-fixincludes.patch
eapply_user
}
diff --git a/sys-devel/gcc/gcc-13.2.1_p20240217.ebuild b/sys-devel/gcc/gcc-13.2.1_p20240217.ebuild
index 1496205dad81..208fc6756f12 100644
--- a/sys-devel/gcc/gcc-13.2.1_p20240217.ebuild
+++ b/sys-devel/gcc/gcc-13.2.1_p20240217.ebuild
@@ -60,6 +60,5 @@ src_prepare() {
toolchain_src_prepare
- eapply "${FILESDIR}"/${PN}-13-fix-cross-fixincludes.patch
eapply_user
}