summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-01 02:58:17 +0100
committerSam James <sam@gentoo.org>2022-09-01 02:58:17 +0100
commit7bd9cba226e32e2a53d7103a62ab58f5289b0c25 (patch)
tree45b249fd5a2764de2ed62c65cbb4293d8a9b0b66 /sys-fs/f2fs-tools
parentsys-fs/f2fs-tools: add github upstream metadata (diff)
downloadgentoo-7bd9cba226e32e2a53d7103a62ab58f5289b0c25.tar.gz
gentoo-7bd9cba226e32e2a53d7103a62ab58f5289b0c25.tar.bz2
gentoo-7bd9cba226e32e2a53d7103a62ab58f5289b0c25.zip
sys-fs/f2fs-tools: fix build w/ app-arch/lz4-1.9.4
Closes: https://bugs.gentoo.org/867691 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/f2fs-tools')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.15.0-r1.ebuild42
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-9999.ebuild2
-rw-r--r--sys-fs/f2fs-tools/files/f2fs-tools-1.15.0-lz4-1.9.4.patch25
3 files changed, 68 insertions, 1 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.15.0-r1.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.15.0-r1.ebuild
new file mode 100644
index 000000000000..654499bcdb8b
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.15.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/9"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="selinux"
+
+RDEPEND="
+ selinux? ( sys-libs/libselinux )
+ elibc_musl? ( sys-libs/queue-standalone )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.15.0-lz4-1.9.4.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # This is required to install to /sbin, bug #481110
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --disable-static \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}
diff --git a/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild b/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
index 106339c983bf..45de5c193d7b 100644
--- a/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
+++ b/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
@@ -25,7 +25,7 @@ src_prepare() {
}
src_configure() {
- #This is required to install to /sbin, bug #481110
+ # This is required to install to /sbin, bug #481110
econf \
--bindir="${EPREFIX}"/sbin \
--disable-static \
diff --git a/sys-fs/f2fs-tools/files/f2fs-tools-1.15.0-lz4-1.9.4.patch b/sys-fs/f2fs-tools/files/f2fs-tools-1.15.0-lz4-1.9.4.patch
new file mode 100644
index 000000000000..4194054271db
--- /dev/null
+++ b/sys-fs/f2fs-tools/files/f2fs-tools-1.15.0-lz4-1.9.4.patch
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/867691
+https://github.com/jaegeuk/f2fs-tools/commit/b9e0985dc2e8f0a15faca21fa208afae57593486
+
+From: Jaegeuk Kim <jaegeuk@kernel.org>
+Date: Mon, 29 Aug 2022 11:03:35 -0700
+Subject: [PATCH] f2fs-tools: fix build error on lz4-1.9.4
+
+LZ4_STREAMSIZE_U64 is undefined in new lz4 lib.
+
+Signed-off-by: Jaegeuk Kim <jaegeuk@kernel.org>
+--- a/fsck/compress.c
++++ b/fsck/compress.c
+@@ -32,10 +32,7 @@
+ #ifdef HAVE_LIBLZ4
+ #define LZ4_MEMORY_USAGE 14
+ #define LZ4_MAX_INPUT_SIZE 0x7E000000 /* 2 113 929 216 bytes */
+-#ifndef LZ4_STREAMSIZE
+-#define LZ4_STREAMSIZE (LZ4_STREAMSIZE_U64 * sizeof(long long))
+-#endif
+-#define LZ4_MEM_COMPRESS LZ4_STREAMSIZE
++#define LZ4_MEM_COMPRESS sizeof(LZ4_stream_t)
+ #define LZ4_ACCELERATION_DEFAULT 1
+ #define LZ4_WORK_SIZE ALIGN_UP(LZ4_MEM_COMPRESS, 8)
+ #endif
+