summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-04-06 23:04:58 +0200
committerDavid Seifert <soap@gentoo.org>2022-04-06 23:04:58 +0200
commit6904371a540ac1e75b52b80dd83e4b486bcf609c (patch)
tree3ed92a21ee1ad406174dea8cac57322412039fe0 /sys-fs
parentdev-libs/libarcus: Stabilize 4.13.1 amd64, #836816 (diff)
downloadgentoo-6904371a540ac1e75b52b80dd83e4b486bcf609c.tar.gz
gentoo-6904371a540ac1e75b52b80dd83e4b486bcf609c.tar.bz2
gentoo-6904371a540ac1e75b52b80dd83e4b486bcf609c.zip
sys-fs/e2fsprogs: fix parallel make bug
Bug: https://bugs.gentoo.org/806875 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.46.5.ebuild1
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.46.5-parallel-make.patch29
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.46.5.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.46.5.ebuild
index 3e84085d14a9..cf2b79c99bc2 100644
--- a/sys-fs/e2fsprogs/e2fsprogs-1.46.5.ebuild
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.46.5.ebuild
@@ -30,6 +30,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
# Upstream patches (can usually removed with next version bump)
+ "${FILESDIR}"/${P}-parallel-make.patch
)
pkg_setup() {
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.46.5-parallel-make.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.46.5-parallel-make.patch
new file mode 100644
index 000000000000..335f6659457d
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.46.5-parallel-make.patch
@@ -0,0 +1,29 @@
+--- a/lib/ext2fs/Makefile.in
++++ b/lib/ext2fs/Makefile.in
+@@ -729,6 +729,12 @@
+ $(top_builddir)/lib/ext2fs/ext2_err.h $(srcdir)/ext2_ext_attr.h \
+ $(srcdir)/hashmap.h $(srcdir)/bitops.h $(srcdir)/bmap64.h $(srcdir)/rbtree.h \
+ $(srcdir)/compiler.h
++blknum.o: $(srcdir)/blknum.c $(top_builddir)/lib/config.h \
++ $(top_builddir)/lib/dirpaths.h $(srcdir)/ext2_fs.h \
++ $(top_builddir)/lib/ext2fs/ext2_types.h $(srcdir)/ext2fs.h \
++ $(srcdir)/ext2_fs.h $(srcdir)/ext3_extents.h $(top_srcdir)/lib/et/com_err.h \
++ $(srcdir)/ext2_io.h $(top_builddir)/lib/ext2fs/ext2_err.h \
++ $(srcdir)/ext2_ext_attr.h $(srcdir)/hashmap.h $(srcdir)/bitops.h
+ block.o: $(srcdir)/block.c $(top_builddir)/lib/config.h \
+ $(top_builddir)/lib/dirpaths.h $(srcdir)/ext2_fs.h \
+ $(top_builddir)/lib/ext2fs/ext2_types.h $(srcdir)/ext2fs.h \
+@@ -837,6 +843,13 @@
+ $(top_builddir)/lib/dirpaths.h $(srcdir)/ext2_fs.h \
+ $(top_builddir)/lib/ext2fs/ext2_types.h $(srcdir)/ext2fsP.h \
+ $(srcdir)/ext2fs.h $(srcdir)/ext2_fs.h $(srcdir)/ext3_extents.h \
++ $(top_srcdir)/lib/et/com_err.h $(srcdir)/ext2_io.h \
++ $(top_builddir)/lib/ext2fs/ext2_err.h $(srcdir)/ext2_ext_attr.h \
++ $(srcdir)/hashmap.h $(srcdir)/bitops.h $(srcdir)/e2image.h
++fallocate.o: $(srcdir)/fallocate.c $(top_builddir)/lib/config.h \
++ $(top_builddir)/lib/dirpaths.h $(srcdir)/ext2_fs.h \
++ $(top_builddir)/lib/ext2fs/ext2_types.h $(srcdir)/ext2fsP.h \
++ $(srcdir)/ext2fs.h $(srcdir)/ext2_fs.h $(srcdir)/ext3_extents.h \
+ $(top_srcdir)/lib/et/com_err.h $(srcdir)/ext2_io.h \
+ $(top_builddir)/lib/ext2fs/ext2_err.h $(srcdir)/ext2_ext_attr.h \
+ $(srcdir)/hashmap.h $(srcdir)/bitops.h $(srcdir)/e2image.h