summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-01-13 08:14:37 +0100
committerAgostino Sarubbo <ago@gentoo.org>2020-01-13 08:14:37 +0100
commit73da8ea5ad3541a21e7585a8cff21163b24c5bb2 (patch)
tree0f561e4e470032da8dbbe45d821eaac583c95afc /sys-kernel
parentdev-ruby/i18n: add 1.8.2 (diff)
downloadgentoo-73da8ea5ad3541a21e7585a8cff21163b24c5bb2.tar.gz
gentoo-73da8ea5ad3541a21e7585a8cff21163b24c5bb2.tar.bz2
gentoo-73da8ea5ad3541a21e7585a8cff21163b24c5bb2.zip
sys-kernel/git-sources: Automated version bump to 5.5_rc6.
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.5_rc6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 96ab42b3f94c..5677e93c50c8 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-5.5-rc2.patch 42752329 BLAKE2B 1365e47a57cb9938f72f7141fe2a0308bc0ca3
DIST patch-5.5-rc3.patch 43336020 BLAKE2B 3bc5729452ab2a07c1a01808f545a80cd69e8eeb317199052ca8678625bfe594a59b2b8aac4e2ace01b0b43394c0014245b0303e2b2b4aa9a055b13d9edeb4ac SHA512 119e1ca3739712a9da5f9c6a019f9ed3536cb1f2e03422093fae042414c2f47b9dff0b02438987af5fdffdba664d7ccb82203d14ee41c6a9a2a07b96877d4ea5
DIST patch-5.5-rc4.patch 43379977 BLAKE2B a38ca7abade329ae966bfafe9f5c616c49d6a2afe2323a2835b4bb37c65d943d7b4b0224355d228a83c7a939aa3daa41b4d496ea2b808456bce2269dc6335bf3 SHA512 7a36ac95a934cfdad4fb1e082157c0e0a63d9658916f0889d4ef38b11c5b7d9ba2e57ec16897cb8987a134c2338ddc757e1f698661c6392cf7890571f6c08a8d
DIST patch-5.5-rc5.patch 43553852 BLAKE2B 06b996fded42eeabc082ede5867b62bfedd75b17fdb72bf34eeee12bb2cf391e7a6c98485fe1bfa2aa2c71a89bf9118ad18fb436d5228c1a81b6d3ceb1595bfd SHA512 ea1e206de9513bce3d6cd67b33f6b2311c141c11f1facdaffa0af09f8057f554a6f05ba682218a9f0f384995e773bbe08e3558263821b13f1c46df54db76bffe
+DIST patch-5.5-rc6.patch 43727222 BLAKE2B e17d108d073441237114984b5615ba17cbd07b7a4521a1b87dd41bf9d4194ad340a9a62adab3ce866151112a55090c3958df5a3c1f3fc6e321c876d70cebf219 SHA512 7596cccb5ac54be9b70d24ff222e20fbbc2285f59bda4402e173b0e6c8dd0060f2544ed688edd5620bca00ffbf93f6262c33a332c64d331854a23ce16589e0c2
diff --git a/sys-kernel/git-sources/git-sources-5.5_rc6.ebuild b/sys-kernel/git-sources/git-sources-5.5_rc6.ebuild
new file mode 100644
index 000000000000..db3e3f95cd35
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.5_rc6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.4"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}