summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-01 06:38:30 +0100
committerSam James <sam@gentoo.org>2023-06-01 06:38:30 +0100
commitff24c8ad26e21dda8d2b0ac23fedc68b11e878a6 (patch)
tree70565ca88029ffc452899be8945db118c4be21c3 /sys-libs/db
parentmedia-video/gpac: Stabilize 2.2.0 amd64, #907576 (diff)
downloadgentoo-ff24c8ad26e21dda8d2b0ac23fedc68b11e878a6.tar.gz
gentoo-ff24c8ad26e21dda8d2b0ac23fedc68b11e878a6.tar.bz2
gentoo-ff24c8ad26e21dda8d2b0ac23fedc68b11e878a6.zip
sys-libs/db: depend on binutils for tc-ld-force-bfd
Otherwise we may get errors like this on clang profiles (report from nvtrxs in #gentoo-hardened): ``` clang-15: error: invalid linker name in argument '-fuse-ld=bfd' ``` Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/db-4.8.30-r8.ebuild2
-rw-r--r--sys-libs/db/db-5.3.28-r9.ebuild6
-rw-r--r--sys-libs/db/db-6.0.35-r4.ebuild4
3 files changed, 10 insertions, 2 deletions
diff --git a/sys-libs/db/db-4.8.30-r8.ebuild b/sys-libs/db/db-4.8.30-r8.ebuild
index e40d00b495fe..f5906a0c970e 100644
--- a/sys-libs/db/db-4.8.30-r8.ebuild
+++ b/sys-libs/db/db-4.8.30-r8.ebuild
@@ -36,6 +36,8 @@ REQUIRED_USE="test? ( tcl )"
DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
+# Need binutils for tc-ld-force-bfd
+BDEPEND="sys-devel/binutils:*"
PATCHES=(
"${FILESDIR}"/${PN}-4.8-libtool.patch
diff --git a/sys-libs/db/db-5.3.28-r9.ebuild b/sys-libs/db/db-5.3.28-r9.ebuild
index 4918af5d46fe..1d029d38e96b 100644
--- a/sys-libs/db/db-5.3.28-r9.ebuild
+++ b/sys-libs/db/db-5.3.28-r9.ebuild
@@ -39,7 +39,11 @@ DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
# bug #841698
-BDEPEND="sys-devel/autoconf-archive"
+# Need binutils for tc-ld-force-bfd
+BDEPEND="
+ sys-devel/autoconf-archive
+ sys-devel/binutils:*
+"
MULTILIB_WRAPPED_HEADERS=(
/usr/include/db${SLOT}/db.h
diff --git a/sys-libs/db/db-6.0.35-r4.ebuild b/sys-libs/db/db-6.0.35-r4.ebuild
index 93dc0fcf54a6..20268a5c9996 100644
--- a/sys-libs/db/db-6.0.35-r4.ebuild
+++ b/sys-libs/db/db-6.0.35-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,6 +38,8 @@ REQUIRED_USE="test? ( tcl )"
DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
+# Need binutils for tc-ld-force-bfd
+BDEPEND="sys-devel/binutils:*"
MULTILIB_WRAPPED_HEADERS=(
/usr/include/db${SLOT}/db.h