summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-03 23:25:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-15 01:21:34 +0200
commit570dc28e6e5bbdc4d2e562e61eb070a2581fae96 (patch)
treec1969076cc304d989a547fcf2407ab1c2c6ff731 /sys-libs/libblockdev
parentsys-cluster/ceph: Drop superfluous calls to python_is_python3 (diff)
downloadgentoo-570dc28e6e5bbdc4d2e562e61eb070a2581fae96.tar.gz
gentoo-570dc28e6e5bbdc4d2e562e61eb070a2581fae96.tar.bz2
gentoo-570dc28e6e5bbdc4d2e562e61eb070a2581fae96.zip
sys-libs/libblockdev: Drop superfluous calls to python_is_python3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-libs/libblockdev')
-rw-r--r--sys-libs/libblockdev/libblockdev-2.23-r1.ebuild13
-rw-r--r--sys-libs/libblockdev/libblockdev-2.24.ebuild13
-rw-r--r--sys-libs/libblockdev/libblockdev-9999.ebuild13
3 files changed, 6 insertions, 33 deletions
diff --git a/sys-libs/libblockdev/libblockdev-2.23-r1.ebuild b/sys-libs/libblockdev/libblockdev-2.23-r1.ebuild
index 105df4812baa..6007c32f473d 100644
--- a/sys-libs/libblockdev/libblockdev-2.23-r1.ebuild
+++ b/sys-libs/libblockdev/libblockdev-2.23-r1.ebuild
@@ -98,18 +98,9 @@ src_configure() {
$(use_with lvm lvm-dbus)
$(use_with tools)
$(use_with vdo)
+ --without-python2
+ --with-python3
)
- if python_is_python3 ; then
- myeconfargs+=(
- --without-python2
- --with-python3
- )
- else
- myeconfargs+=(
- --with-python2
- --without-python3
- )
- fi
econf "${myeconfargs[@]}"
}
diff --git a/sys-libs/libblockdev/libblockdev-2.24.ebuild b/sys-libs/libblockdev/libblockdev-2.24.ebuild
index c252b7d2104f..2d41db827580 100644
--- a/sys-libs/libblockdev/libblockdev-2.24.ebuild
+++ b/sys-libs/libblockdev/libblockdev-2.24.ebuild
@@ -96,18 +96,9 @@ src_configure() {
$(use_with lvm lvm-dbus)
$(use_with tools)
$(use_with vdo)
+ --without-python2
+ --with-python3
)
- if python_is_python3 ; then
- myeconfargs+=(
- --without-python2
- --with-python3
- )
- else
- myeconfargs+=(
- --with-python2
- --without-python3
- )
- fi
econf "${myeconfargs[@]}"
}
diff --git a/sys-libs/libblockdev/libblockdev-9999.ebuild b/sys-libs/libblockdev/libblockdev-9999.ebuild
index 1ea252a8b26c..214de07c57c9 100644
--- a/sys-libs/libblockdev/libblockdev-9999.ebuild
+++ b/sys-libs/libblockdev/libblockdev-9999.ebuild
@@ -96,18 +96,9 @@ src_configure() {
$(use_with lvm lvm-dbus)
$(use_with tools)
$(use_with vdo)
+ --without-python2
+ --with-python3
)
- if python_is_python3 ; then
- myeconfargs+=(
- --without-python2
- --with-python3
- )
- else
- myeconfargs+=(
- --with-python2
- --without-python3
- )
- fi
econf "${myeconfargs[@]}"
}