summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-02-08 11:36:11 -0500
committerMike Gilbert <floppym@gentoo.org>2018-02-08 11:36:11 -0500
commitc1ec0a7a814111a7eccf8f18102a16d08b0f3ce7 (patch)
treed7c032cb16c47836ccaa45563e2c23b7dc70c154 /sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild
parentsys-devel/gcc: Stable for HPPA too. (diff)
downloadgentoo-c1ec0a7a814111a7eccf8f18102a16d08b0f3ce7.tar.gz
gentoo-c1ec0a7a814111a7eccf8f18102a16d08b0f3ce7.tar.bz2
gentoo-c1ec0a7a814111a7eccf8f18102a16d08b0f3ce7.zip
sys-libs/libcap-ng: bump to 0.7.9
Package-Manager: Portage-2.3.24, Repoman-2.3.6_p81
Diffstat (limited to 'sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild')
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild
new file mode 100644
index 000000000000..850239d9c237
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.7.9.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit flag-o-matic python-r1
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="https://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="https://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ python? ( >=dev-lang/swig-2 )"
+
+src_configure() {
+ use sparc && replace-flags -O? -O0
+
+ local ECONF_SOURCE=${S}
+
+ local myconf=(
+ $(use_enable static-libs static)
+ )
+
+ local pythonconf=( --without-python --without-python3 )
+
+ # set up python bindings build(s)
+ if use python ; then
+ setup_python_flags_configure() {
+ if python_is_python3; then
+ pythonconf=( --without-python --with-python3 )
+ else
+ pythonconf=( --with-python --without-python3 )
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
+ }
+
+ python_foreach_impl setup_python_flags_configure
+ else
+ local BUILD_DIR=${WORKDIR}/build
+ run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir emake
+ else
+ local BUILD_DIR=${WORKDIR}/build
+ emake -C "${BUILD_DIR}"
+ fi
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ ewarn "Skipping tests due to root permissions."
+ return
+ fi
+
+ if use python; then
+ python_foreach_impl run_in_build_dir emake check
+ else
+ local BUILD_DIR=${WORKDIR}/build
+ emake -C "${BUILD_DIR}" check
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ else
+ local BUILD_DIR=${WORKDIR}/build
+ emake -C "${BUILD_DIR}" DESTDIR="${D}" install
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}