summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-09 05:36:24 +0100
committerSam James <sam@gentoo.org>2023-07-09 05:36:30 +0100
commitfa60a8dafebb7a2332a5d3cac1e1d620094ed9f2 (patch)
tree62eb8816cb1c8c430a6ade3b95ecddd511f66a9d /sys-libs/libnvme
parentdev-python/zeroconf: Stabilize 0.69.0 amd64, #910075 (diff)
downloadgentoo-fa60a8dafebb7a2332a5d3cac1e1d620094ed9f2.tar.gz
gentoo-fa60a8dafebb7a2332a5d3cac1e1d620094ed9f2.tar.bz2
gentoo-fa60a8dafebb7a2332a5d3cac1e1d620094ed9f2.zip
sys-libs/libnvme: tweak style to match skel.ebuild
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/libnvme')
-rw-r--r--sys-libs/libnvme/libnvme-1.5.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-libs/libnvme/libnvme-1.5.ebuild b/sys-libs/libnvme/libnvme-1.5.ebuild
index 3502d35610d0..f00e46205f84 100644
--- a/sys-libs/libnvme/libnvme-1.5.ebuild
+++ b/sys-libs/libnvme/libnvme-1.5.ebuild
@@ -8,12 +8,16 @@ inherit python-r1 meson
DESCRIPTION="C Library for NVM Express on Linux"
HOMEPAGE="https://github.com/linux-nvme/libnvme"
+SRC_URI="https://github.com/linux-nvme/libnvme/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="LGPL-2.1+"
SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
IUSE="dbus +json keyutils python ssl +uuid"
-SRC_URI="https://github.com/linux-nvme/libnvme/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
DEPEND="
json? ( dev-libs/json-c:= )
@@ -29,10 +33,6 @@ BDEPEND="
dev-lang/swig
"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
src_configure() {
local emesonargs=(
-Dpython=false