summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-12-17 12:00:42 +0100
committerSam James <sam@gentoo.org>2023-12-17 11:44:59 +0000
commit9c23fa50904bbb495578a8547f6918b0c4f96614 (patch)
treeca8b03743865fd8bef3e90c50e22c2c960717f28 /sys-libs/musl
parentdev-python/setuptools-gettext: Add a patch to fix wheel building (diff)
downloadgentoo-9c23fa50904bbb495578a8547f6918b0c4f96614.tar.gz
gentoo-9c23fa50904bbb495578a8547f6918b0c4f96614.tar.bz2
gentoo-9c23fa50904bbb495578a8547f6918b0c4f96614.zip
sys-libs/musl: use https for git clone
git:// is unencrypted and could be used by an attacker (mitm) to insert malicious code, see also [1]. I think especially for such a critical system package like musl it's better to use the more secure https variant. git:// runs on port 9418 which is also less likely open behind a firewall. [1] git-scm.com/book/en/v2/Git-on-the-Server-The-Protocols [sam: I think musl only recently started to support this when they changed httpds in the last week.] Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/34319 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/musl')
-rw-r--r--sys-libs/musl/musl-1.2.3-r7.ebuild2
-rw-r--r--sys-libs/musl/musl-1.2.3-r8.ebuild2
-rw-r--r--sys-libs/musl/musl-1.2.3.ebuild2
-rw-r--r--sys-libs/musl/musl-1.2.4-r1.ebuild2
-rw-r--r--sys-libs/musl/musl-1.2.4.ebuild2
-rw-r--r--sys-libs/musl/musl-9999.ebuild2
6 files changed, 6 insertions, 6 deletions
diff --git a/sys-libs/musl/musl-1.2.3-r7.ebuild b/sys-libs/musl/musl-1.2.3-r7.ebuild
index efb999922037..a201a7574d4a 100644
--- a/sys-libs/musl/musl-1.2.3-r7.ebuild
+++ b/sys-libs/musl/musl-1.2.3-r7.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit eapi8-dosym flag-o-matic toolchain-funcs prefix
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ EGIT_REPO_URI="https://git.musl-libc.org/git/musl"
inherit git-r3
else
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/musl.asc
diff --git a/sys-libs/musl/musl-1.2.3-r8.ebuild b/sys-libs/musl/musl-1.2.3-r8.ebuild
index dfe257f84b9d..f8962b382f48 100644
--- a/sys-libs/musl/musl-1.2.3-r8.ebuild
+++ b/sys-libs/musl/musl-1.2.3-r8.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit eapi8-dosym flag-o-matic toolchain-funcs prefix
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ EGIT_REPO_URI="https://git.musl-libc.org/git/musl"
inherit git-r3
else
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/musl.asc
diff --git a/sys-libs/musl/musl-1.2.3.ebuild b/sys-libs/musl/musl-1.2.3.ebuild
index 9e1f93d9db53..850138951e5e 100644
--- a/sys-libs/musl/musl-1.2.3.ebuild
+++ b/sys-libs/musl/musl-1.2.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit eapi8-dosym flag-o-matic toolchain-funcs prefix
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ EGIT_REPO_URI="https://git.musl-libc.org/git/musl"
inherit git-r3
else
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/musl.asc
diff --git a/sys-libs/musl/musl-1.2.4-r1.ebuild b/sys-libs/musl/musl-1.2.4-r1.ebuild
index 899ae673cc90..1d1973c35acc 100644
--- a/sys-libs/musl/musl-1.2.4-r1.ebuild
+++ b/sys-libs/musl/musl-1.2.4-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
inherit crossdev flag-o-matic toolchain-funcs prefix
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ EGIT_REPO_URI="https://git.musl-libc.org/git/musl"
inherit git-r3
else
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/musl.asc
diff --git a/sys-libs/musl/musl-1.2.4.ebuild b/sys-libs/musl/musl-1.2.4.ebuild
index c41674ff8142..2908fbd17541 100644
--- a/sys-libs/musl/musl-1.2.4.ebuild
+++ b/sys-libs/musl/musl-1.2.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
inherit crossdev flag-o-matic toolchain-funcs prefix
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ EGIT_REPO_URI="https://git.musl-libc.org/git/musl"
inherit git-r3
else
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/musl.asc
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index c41674ff8142..2908fbd17541 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
inherit crossdev flag-o-matic toolchain-funcs prefix
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ EGIT_REPO_URI="https://git.musl-libc.org/git/musl"
inherit git-r3
else
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/musl.asc