summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-03 17:25:03 +0000
committerSam James <sam@gentoo.org>2021-11-03 17:26:51 +0000
commit609d72bc35743b798c849b1b6d33cbfcf40b3b15 (patch)
tree71d055ab42d6a3ca75292e544dc3aabd08df3da9 /sys-libs
parentx11-wm/i3-gaps: add 4.20.1 (diff)
downloadgentoo-609d72bc35743b798c849b1b6d33cbfcf40b3b15.tar.gz
gentoo-609d72bc35743b798c849b1b6d33cbfcf40b3b15.tar.bz2
gentoo-609d72bc35743b798c849b1b6d33cbfcf40b3b15.zip
sys-libs/glibc: drop crypt.h preservation workaround
Python was the main culprit and now that the erroneous/redundant include of crypt.h (and separately, -lcrypt linkage) has been dropped (and hence no longer affecting any consumers of Python.h and libpython). Hence, we can drop this as it was causing _more_ issues than it prevented as folks were still using FEATURES="collision-protect" instead of FEATURES="unmerge-orphans" (the news item and postinst did mention this, though). Bug: https://bugs.gentoo.org/802210 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.33-r7.ebuild14
-rw-r--r--sys-libs/glibc/glibc-2.34.ebuild15
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild14
3 files changed, 3 insertions, 40 deletions
diff --git a/sys-libs/glibc/glibc-2.33-r7.ebuild b/sys-libs/glibc/glibc-2.33-r7.ebuild
index 146cce876a7f..4fb9888470fb 100644
--- a/sys-libs/glibc/glibc-2.33-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.33-r7.ebuild
@@ -1506,12 +1506,6 @@ pkg_preinst() {
if ! use crypt && has_version "${CATEGORY}/${PN}[crypt]"; then
PRESERVED_OLD_LIBCRYPT=1
preserve_old_lib /$(get_libdir)/libcrypt$(get_libname 1)
-
- # Only copy if it exists; some people may have tiny embedded
- # systems without headers: https://bugs.gentoo.org/802207#c16.
- if [[ -f "${EROOT}"/usr/include/crypt.h ]] ; then
- cp "${EROOT}"/usr/include/crypt.h "${T}"/crypt.h || die
- fi
else
PRESERVED_OLD_LIBCRYPT=0
fi
@@ -1548,14 +1542,8 @@ pkg_postinst() {
if [[ ${PRESERVED_OLD_LIBCRYPT} -eq 1 ]] ; then
preserve_old_lib_notify /$(get_libdir)/libcrypt$(get_libname 1)
- # Only copy if it exists; some people may have tiny embedded
- # systems without headers: https://bugs.gentoo.org/802207#c16
- if [[ -f "${T}"/crypt.h ]] ; then
- cp "${T}"/crypt.h "${EROOT}"/usr/include/crypt.h || eerror "Error restoring crypt.h, please file a bug"
- fi
-
elog "Please ignore a possible later error message about a file collision involving"
- elog "/usr/include/crypt.h. We need to preserve this file for the moment to keep"
+ elog "${EROOT}/$(get_libdir)/libcrypt$(get_libname 1). We need to preserve this file for the moment to keep"
elog "the upgrade working, but it also needs to be overwritten when"
elog "sys-libs/libxcrypt is installed. See bug 802210 for more details."
elog "If you have FEATURES=collision-protect, please use FEATURES=unmerge-orphans instead!"
diff --git a/sys-libs/glibc/glibc-2.34.ebuild b/sys-libs/glibc/glibc-2.34.ebuild
index f292dc31fc3b..e98c13cc390b 100644
--- a/sys-libs/glibc/glibc-2.34.ebuild
+++ b/sys-libs/glibc/glibc-2.34.ebuild
@@ -1519,13 +1519,6 @@ pkg_preinst() {
if ! use crypt && has_version "${CATEGORY}/${PN}[crypt]"; then
PRESERVED_OLD_LIBCRYPT=1
preserve_old_lib /$(get_libdir)/libcrypt$(get_libname 1)
-
- # Only copy if it exists; some people may have tiny embedded
- # systems without headers: https://bugs.gentoo.org/802207#c16
- if [[ -f "${EROOT}"/usr/include/crypt.h ]] ; then
- cp "${EROOT}"/usr/include/crypt.h "${T}"/crypt.h || die
- fi
-
else
PRESERVED_OLD_LIBCRYPT=0
fi
@@ -1562,14 +1555,8 @@ pkg_postinst() {
if [[ ${PRESERVED_OLD_LIBCRYPT} -eq 1 ]] ; then
preserve_old_lib_notify /$(get_libdir)/libcrypt$(get_libname 1)
- # Only copy if it exists; some people may have tiny embedded
- # systems without headers: https://bugs.gentoo.org/802207#c16
- if [[ -f "${T}"/crypt.h ]] ; then
- cp "${T}"/crypt.h "${EROOT}"/usr/include/crypt.h || eerror "Error restoring crypt.h, please file a bug"
- fi
-
elog "Please ignore a possible later error message about a file collision involving"
- elog "/usr/include/crypt.h. We need to preserve this file for the moment to keep"
+ elog "${EROOT}/$(get_libdir)/libcrypt$(get_libname 1). We need to preserve this file for the moment to keep"
elog "the upgrade working, but it also needs to be overwritten when"
elog "sys-libs/libxcrypt is installed. See bug 802210 for more details."
fi
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index ce817f25421f..c1752e4d398d 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1519,12 +1519,6 @@ pkg_preinst() {
if ! use crypt && has_version "${CATEGORY}/${PN}[crypt]"; then
PRESERVED_OLD_LIBCRYPT=1
preserve_old_lib /$(get_libdir)/libcrypt$(get_libname 1)
-
- # Only copy if it exists; some people may have tiny embedded
- # systems without headers: https://bugs.gentoo.org/802207#c16
- if [[ -f "${EROOT}"/usr/include/crypt.h ]] ; then
- cp "${EROOT}"/usr/include/crypt.h "${T}"/crypt.h || die
- fi
else
PRESERVED_OLD_LIBCRYPT=0
fi
@@ -1561,14 +1555,8 @@ pkg_postinst() {
if [[ ${PRESERVED_OLD_LIBCRYPT} -eq 1 ]] ; then
preserve_old_lib_notify /$(get_libdir)/libcrypt$(get_libname 1)
- # Only copy if it exists; some people may have tiny embedded
- # systems without headers: https://bugs.gentoo.org/802207#c16
- if [[ -f "${T}"/crypt.h ]] ; then
- cp "${T}"/crypt.h "${EROOT}"/usr/include/crypt.h || eerror "Error restoring crypt.h, please file a bug"
- fi
-
elog "Please ignore a possible later error message about a file collision involving"
- elog "/usr/include/crypt.h. We need to preserve this file for the moment to keep"
+ elog "${EROOT}/$(get_libdir)/libcrypt$(get_libname 1). We need to preserve this file for the moment to keep"
elog "the upgrade working, but it also needs to be overwritten when"
elog "sys-libs/libxcrypt is installed. See bug 802210 for more details."
fi