summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-12-17 23:26:52 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-12-17 23:27:11 +0100
commitabbc4ee764485b39ca6e9861fc3f54b4c793a99b (patch)
tree747d1bb355c1130acbec26a5a00e16304d67e5de /sys-libs
parentmedia-libs/speex: Switch to https (diff)
downloadgentoo-abbc4ee764485b39ca6e9861fc3f54b4c793a99b.tar.gz
gentoo-abbc4ee764485b39ca6e9861fc3f54b4c793a99b.tar.bz2
gentoo-abbc4ee764485b39ca6e9861fc3f54b4c793a99b.zip
sys-libs/glibc: Add useflag doc; controlls installation of manual and dependency on texinfo, bug 616190
Closes: https://bugs.gentoo.org/616190 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.26-r3.ebuild11
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild11
2 files changed, 18 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.26-r3.ebuild b/sys-libs/glibc/glibc-2.26-r3.ebuild
index 88a9cd4b5b3d..ceb5b6846859 100644
--- a/sys-libs/glibc/glibc-2.26-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.26-r3.ebuild
@@ -32,7 +32,7 @@ PATCH_VER=4
SRC_URI+=" https://dev.gentoo.org/~dilfridge/distfiles/${P}-patches-${PATCH_VER}.tar.bz2"
SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-${GCC_BOOTSTRAP_VER}-multilib-bootstrap.tar.bz2 )"
-IUSE="audit caps debug gd hardened multilib nscd selinux systemtap profile suid vanilla crosscompile_opts_headers-only"
+IUSE="audit caps debug doc gd hardened multilib nscd selinux systemtap profile suid vanilla crosscompile_opts_headers-only"
# Min kernel version glibc requires
: ${NPTL_KERN_VER:="3.2.0"}
@@ -80,6 +80,7 @@ DEPEND="${COMMON_DEPEND}
>=app-misc/pax-utils-0.1.10
!<sys-apps/sandbox-1.6
!<sys-apps/portage-2.1.2
+ doc? ( sys-apps/texinfo )
"
RDEPEND="${COMMON_DEPEND}
!sys-kernel/ps3-sources
@@ -286,8 +287,14 @@ glibc_do_configure() {
einfo "Configuring glibc for $1"
+ if use doc ; then
+ export MAKEINFO=makeinfo
+ else
+ export MAKEINFO=/dev/null
+ fi
+
local v
- for v in ABI CBUILD CHOST CTARGET CBUILD_OPT CTARGET_OPT CC CXX LD {AS,C,CPP,CXX,LD}FLAGS ; do
+ for v in ABI CBUILD CHOST CTARGET CBUILD_OPT CTARGET_OPT CC CXX LD {AS,C,CPP,CXX,LD}FLAGS MAKEINFO ; do
einfo " $(printf '%15s' ${v}:) ${!v}"
done
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index a3b427221e28..68d17a224695 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -33,7 +33,7 @@ PATCH_VER="3"
SRC_URI+=" https://dev.gentoo.org/~dilfridge/distfiles/${P}-patches-${PATCH_VER}.tar.bz2"
SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-${GCC_BOOTSTRAP_VER}-multilib-bootstrap.tar.bz2 )"
-IUSE="audit caps compile-locales debug gd hardened multilib nscd selinux systemtap profile suid vanilla crosscompile_opts_headers-only"
+IUSE="audit caps compile-locales debug doc gd hardened multilib nscd selinux systemtap profile suid vanilla crosscompile_opts_headers-only"
# Min kernel version glibc requires
: ${NPTL_KERN_VER:="3.2.0"}
@@ -85,6 +85,7 @@ DEPEND="${COMMON_DEPEND}
>=app-misc/pax-utils-0.1.10
!<sys-apps/sandbox-1.6
!<sys-apps/portage-2.1.2
+ doc? ( sys-apps/texinfo )
"
RDEPEND="${COMMON_DEPEND}
!sys-kernel/ps3-sources
@@ -298,8 +299,14 @@ glibc_do_configure() {
einfo "Configuring glibc for nptl"
+ if use doc ; then
+ export MAKEINFO=makeinfo
+ else
+ export MAKEINFO=/dev/null
+ fi
+
local v
- for v in ABI CBUILD CHOST CTARGET CBUILD_OPT CTARGET_OPT CC CXX LD {AS,C,CPP,CXX,LD}FLAGS ; do
+ for v in ABI CBUILD CHOST CTARGET CBUILD_OPT CTARGET_OPT CC CXX LD {AS,C,CPP,CXX,LD}FLAGS MAKEINFO ; do
einfo " $(printf '%15s' ${v}:) ${!v}"
done