summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/bcron
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/bcron')
-rw-r--r--sys-process/bcron/Manifest1
-rw-r--r--sys-process/bcron/bcron-0.09-r2.ebuild116
-rw-r--r--sys-process/bcron/bcron-0.09.ebuild111
-rw-r--r--sys-process/bcron/files/bcron-0.09-fix-parallel-build.patch19
-rw-r--r--sys-process/bcron/files/bcron-0.09-fix-socket-permissions.patch10
-rw-r--r--sys-process/bcron/files/crontab15
-rw-r--r--sys-process/bcron/metadata.xml13
7 files changed, 285 insertions, 0 deletions
diff --git a/sys-process/bcron/Manifest b/sys-process/bcron/Manifest
new file mode 100644
index 000000000000..76324e8565a6
--- /dev/null
+++ b/sys-process/bcron/Manifest
@@ -0,0 +1 @@
+DIST bcron-0.09.tar.gz 57584 RMD160 a7ae646635c2da2a71803020f890453fac62f6d5 SHA1 d2136f1de412b7d8be0adbef298411a1ee1908f0 SHA256 c547ff95ca2f0fb7d4bfd6c3f81cc9f099fe287b566c9511d9d9930380b004c8
diff --git a/sys-process/bcron/bcron-0.09-r2.ebuild b/sys-process/bcron/bcron-0.09-r2.ebuild
new file mode 100644
index 000000000000..2b1675a600ea
--- /dev/null
+++ b/sys-process/bcron/bcron-0.09-r2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit cron eutils toolchain-funcs multilib
+DESCRIPTION="A new cron system designed with secure operations in mind by Bruce Guenter"
+
+HOMEPAGE="http://untroubled.org/bcron/"
+SRC_URI="http://untroubled.org/bcron/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/bglibs-1.106"
+RDEPEND=">=sys-process/cronbase-0.3.2
+ virtual/mta
+ sys-apps/ucspi-unix
+ virtual/daemontools"
+
+CRON_SYSTEM_CRONTAB="yes"
+
+src_prepare() {
+ epatch "${FILESDIR}/bcron-0.09-fix-parallel-build.patch"
+ epatch "${FILESDIR}/bcron-0.09-fix-socket-permissions.patch"
+}
+
+src_configure() {
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/$(get_libdir)/bglibs" > conf-bglibs
+ echo "${D}/usr/bin" > conf-bin
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ einstall || die
+
+ #fix permissions of crontab
+ fperms o-rwx /usr/bin/bcrontab
+ fowners root:cron /usr/bin/bcrontab
+
+ doman bcrontab.1 crontab.5 bcron-update.8 bcron-start.8
+ doman bcron-spool.8 bcron-sched.8 bcron-exec.8
+
+ dodoc ANNOUNCEMENT NEWS README TODO
+
+ keepdir /etc/cron.d
+
+ keepdir /var/spool/cron/crontabs
+ keepdir /var/spool/cron/tmp
+
+ for i in crontabs tmp;
+ do
+ fowners cron:cron /var/spool/cron/$i
+ fperms go-rwx /var/spool/cron/$i
+ done
+
+ dodir /etc/bcron
+
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+
+ insinto /var/lib/supervise/bcron
+ doins bcron-sched.run
+
+ insinto /var/lib/supervise/bcron/log
+ doins bcron-sched-log.run
+
+ insinto /var/lib/supervise/bcron-spool
+ doins bcron-spool.run
+
+ insinto /var/lib/supervise/bcron-update
+ doins bcron-update.run
+}
+
+pkg_config() {
+ cd "${ROOT}"var/lib/supervise/bcron
+ [ -e run ] && cp run bcron-sched.run.`date +%Y%m%d%H%M%S`
+ cp bcron-sched.run run
+ chmod u+x run
+
+ cd "${ROOT}"/var/lib/supervise/bcron/log
+ [ -e run ] && cp run bcron-sched-log.run.`date +%Y%m%d%H%M%S`
+ cp bcron-sched-log.run run
+ chmod u+x run
+
+ cd "${ROOT}"/var/lib/supervise/bcron-spool
+ [ -e run ] && cp run bcron-spool.run.`date +%Y%m%d%H%M%S`
+ cp bcron-spool.run run
+ chmod u+x run
+
+ cd "${ROOT}"/var/lib/supervise/bcron-update
+ [ -e run ] && cp run bcron-update.run.`date +%Y%m%d%H%M%S`
+ cp bcron-update.run run
+ chmod u+x run
+
+ [ ! -e "${ROOT}"/var/spool/cron/trigger ] && mkfifo "${ROOT}"var/spool/cron/trigger
+ chown cron:cron /var/spool/cron/trigger
+ chmod go-rwx /var/spool/cron/trigger
+}
+
+pkg_postinst() {
+ echo
+ elog "Run "
+ elog "emerge --config =${PF}"
+ elog "to create or update your run files (backups are created) in"
+ elog " /var/lib/supervise/bcron (bcron daemon) and"
+ elog " /var/lib/supervise/bcron-spool (crontab receiver) and"
+ elog " /var/lib/supervise/bcron-update (system crontab updater)"
+
+ cron_pkg_postinst
+}
diff --git a/sys-process/bcron/bcron-0.09.ebuild b/sys-process/bcron/bcron-0.09.ebuild
new file mode 100644
index 000000000000..380ad7b56950
--- /dev/null
+++ b/sys-process/bcron/bcron-0.09.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+CRON_SYSTEM_CRONTAB="yes"
+
+inherit cron eutils toolchain-funcs
+DESCRIPTION="A new cron system designed with secure operations in mind by Bruce Guenter"
+
+HOMEPAGE="http://untroubled.org/bcron/"
+SRC_URI="http://untroubled.org/bcron/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=dev-libs/bglibs-1.031"
+RDEPEND=">=sys-process/cronbase-0.3.2
+ virtual/mta
+ sys-apps/ucspi-unix
+ virtual/daemontools"
+
+src_compile() {
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/lib/bglibs" > conf-bglibs
+ echo "${D}/usr/bin" > conf-bin
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ # bug #278459
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ einstall || die
+
+ #fix permissions of crontab
+ fperms o-rwx /usr/bin/bcrontab
+ fowners root:cron /usr/bin/bcrontab
+
+ doman bcrontab.1 crontab.5 bcron-update.8 bcron-start.8
+ doman bcron-spool.8 bcron-sched.8 bcron-exec.8
+
+ dodoc ANNOUNCEMENT NEWS README TODO
+
+ keepdir /etc/cron.d
+
+ keepdir /var/spool/cron/crontabs
+ keepdir /var/spool/cron/tmp
+
+ for i in crontabs tmp;
+ do
+ fowners cron:cron /var/spool/cron/$i
+ fperms go-rwx /var/spool/cron/$i
+ done
+
+ dodir /etc/bcron
+
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+
+ insinto /var/lib/supervise/bcron
+ doins bcron-sched.run
+
+ insinto /var/lib/supervise/bcron/log
+ doins bcron-sched-log.run
+
+ insinto /var/lib/supervise/bcron-spool
+ doins bcron-spool.run
+
+ insinto /var/lib/supervise/bcron-update
+ doins bcron-update.run
+}
+
+pkg_config() {
+ cd "${ROOT}"var/lib/supervise/bcron
+ [ -e run ] && cp run bcron-sched.run.`date +%Y%m%d%H%M%S`
+ cp bcron-sched.run run
+ chmod u+x run
+
+ cd "${ROOT}"/var/lib/supervise/bcron/log
+ [ -e run ] && cp run bcron-sched-log.run.`date +%Y%m%d%H%M%S`
+ cp bcron-sched-log.run run
+ chmod u+x run
+
+ cd "${ROOT}"/var/lib/supervise/bcron-spool
+ [ -e run ] && cp run bcron-spool.run.`date +%Y%m%d%H%M%S`
+ cp bcron-spool.run run
+ chmod u+x run
+
+ cd "${ROOT}"/var/lib/supervise/bcron-update
+ [ -e run ] && cp run bcron-update.run.`date +%Y%m%d%H%M%S`
+ cp bcron-update.run run
+ chmod u+x run
+
+ [ ! -e "${ROOT}"/var/spool/cron/trigger ] && mkfifo "${ROOT}"var/spool/cron/trigger
+ chown cron:cron /var/spool/cron/trigger
+ chmod go-rwx /var/spool/cron/trigger
+}
+
+pkg_postinst() {
+ echo
+ elog "Run "
+ elog "emerge --config =${PF}"
+ elog "to create or update your run files (backups are created) in"
+ elog " /var/lib/supervise/bcron (bcron daemon) and"
+ elog " /var/lib/supervise/bcron-spool (crontab receiver) and"
+ elog " /var/lib/supervise/bcron-update (system crontab updater)"
+
+ cron_pkg_postinst
+}
diff --git a/sys-process/bcron/files/bcron-0.09-fix-parallel-build.patch b/sys-process/bcron/files/bcron-0.09-fix-parallel-build.patch
new file mode 100644
index 000000000000..987b302abe4f
--- /dev/null
+++ b/sys-process/bcron/files/bcron-0.09-fix-parallel-build.patch
@@ -0,0 +1,19 @@
+--- Makefile.orig 2010-01-14 15:39:07.000000000 +0100
++++ Makefile 2010-01-14 15:39:40.000000000 +0100
+@@ -96,14 +96,14 @@
+ ./load insthier -lbg-installer -lbg
+ mv insthier installer
+
+-instcheck: load insthier.o
++instcheck: load insthier.o installer instshow
+ ./load insthier -lbg-instcheck -lbg
+ mv insthier instcheck
+
+ insthier.o: compile insthier.c conf_bin.c
+ ./compile insthier.c
+
+-instshow: load insthier.o
++instshow: load insthier.o installer
+ ./load insthier -lbg-instshow -lbg
+ mv insthier instshow
+
diff --git a/sys-process/bcron/files/bcron-0.09-fix-socket-permissions.patch b/sys-process/bcron/files/bcron-0.09-fix-socket-permissions.patch
new file mode 100644
index 000000000000..a8b13038e608
--- /dev/null
+++ b/sys-process/bcron/files/bcron-0.09-fix-socket-permissions.patch
@@ -0,0 +1,10 @@
+--- a/bcron-spool.run 2005-06-09 04:14:42.000000000 +0400
++++ b/bcron-spool/run 2010-07-12 01:29:24.000000000 +0400
+@@ -5,6 +5,6 @@
+ envuidgid cron \
+ sh -c '
+ exec \
+-unixserver -U ${BCRON_SOCKET:-/var/run/bcron-spool} \
++unixserver -U ${BCRON_SOCKET:-/var/run/bcron-spool} -r 16 -p 0660 \
+ bcron-spool
+ '
diff --git a/sys-process/bcron/files/crontab b/sys-process/bcron/files/crontab
new file mode 100644
index 000000000000..318d0e40879f
--- /dev/null
+++ b/sys-process/bcron/files/crontab
@@ -0,0 +1,15 @@
+# for bcron
+# $Id$
+
+# Global variables
+SHELL=/bin/bash
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+MAILTO=root
+HOME=/
+
+# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
+59 * * * * root rm -f /var/spool/cron/lastrun/cron.hourly
+9 3 * * * root rm -f /var/spool/cron/lastrun/cron.daily
+19 4 * * 6 root rm -f /var/spool/cron/lastrun/cron.weekly
+29 5 1 * * root rm -f /var/spool/cron/lastrun/cron.monthly
+*/10 * * * * root test -x /usr/sbin/run-crons && /usr/sbin/run-crons
diff --git a/sys-process/bcron/metadata.xml b/sys-process/bcron/metadata.xml
new file mode 100644
index 000000000000..2ba9b9520d07
--- /dev/null
+++ b/sys-process/bcron/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cron</herd>
+ <longdescription>
+ This is bcron, a new cron system designed with secure operations in
+ mind. To do this, the system is divided into several seperate programs,
+ each responsible for a seperate task, with strictly controlled
+ communications between them. The user interface is a drop-in
+ replacement for similar systems (such as vixie-cron), but the internals
+ differ greatly.
+ </longdescription>
+</pkgmetadata>