summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-05-31 10:25:02 -0400
committerCraig Andrews <candrews@gentoo.org>2023-05-31 10:25:27 -0400
commit2b19e87ecf8a89ed256cbf6b59d424dc58c18ac5 (patch)
treedad7099a6a29425e281c89e8fbd2167b7976e90e /www-apache/mod_h2
parentdev-python/apipkg: Add GH remote-id (diff)
downloadgentoo-2b19e87ecf8a89ed256cbf6b59d424dc58c18ac5.tar.gz
gentoo-2b19e87ecf8a89ed256cbf6b59d424dc58c18ac5.tar.bz2
gentoo-2b19e87ecf8a89ed256cbf6b59d424dc58c18ac5.zip
www-apache/mod_h2: add 2.0.18
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_h2')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.18.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 8d457e5a816d..2965356cde1f 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.17.tar.gz 797498 BLAKE2B 07149360401dc1aee333e8f3a06d9a2248e33227da1a835d6f5599a7f312183f26537e0d7ef1fbb63423418bb303d08597847b713838f139691e65b9a8211c5e SHA512 48b2e247a9cd3c9ef3f20066b8cd341d35a5f3b324dac0fc8732b78c1f6bcc4f111fee317dec083dc98355ff81d62df2dcc4450e53d6a85e7e5ff649d3f81411
+DIST mod_h2-2.0.18.tar.gz 798216 BLAKE2B f57116608da33a73f0e8811a78318234afaed69dea479503bd022096748d8604b744255b406b5025ed9a4bbbb78175b8c9c44a78af538d749bad46c0f8b141b6 SHA512 6e44a27722977e2ff9339a51557644072c3b154134b8273519b8f0de29759e9a7c982e92f66c9746bd34818b86089ae19f62980816853b576c8fb71b1ec5ea2d
diff --git a/www-apache/mod_h2/mod_h2-2.0.18.ebuild b/www-apache/mod_h2/mod_h2-2.0.18.ebuild
new file mode 100644
index 000000000000..5ba43634b8e0
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.18.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}