summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-06-01 23:15:56 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-06-01 23:15:56 +0200
commit56c4cfd704cae6488d0d06b5ab581a98af40dd2b (patch)
tree1554ed6be2ab2014bc84935e5013f580eb1fdf76 /www-apps/webmcp/webmcp-1.2.6.ebuild
parentdev-python/jsonschema: stable 3.2.0 for ppc (diff)
downloadgentoo-56c4cfd704cae6488d0d06b5ab581a98af40dd2b.tar.gz
gentoo-56c4cfd704cae6488d0d06b5ab581a98af40dd2b.tar.bz2
gentoo-56c4cfd704cae6488d0d06b5ab581a98af40dd2b.zip
www-apps/webmcp: EAPI 7 & respect LDFLAGS
Closes: https://bugs.gentoo.org/726086 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'www-apps/webmcp/webmcp-1.2.6.ebuild')
-rw-r--r--www-apps/webmcp/webmcp-1.2.6.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/www-apps/webmcp/webmcp-1.2.6.ebuild b/www-apps/webmcp/webmcp-1.2.6.ebuild
index 8442fcfc0a2f..a156ac3bbf96 100644
--- a/www-apps/webmcp/webmcp-1.2.6.ebuild
+++ b/www-apps/webmcp/webmcp-1.2.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_P=${PN}-v${PV}
DESCRIPTION="Web application framework written in Lua and C"
@@ -15,18 +15,16 @@ KEYWORDS="~amd64"
SLOT=0
IUSE=""
-RDEPEND="dev-lang/lua
- dev-db/postgresql"
+RDEPEND="dev-lang/lua:=
+ dev-db/postgresql:="
DEPEND="${RDEPEND}"
S="${WORKDIR}"/${MY_P}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_compile() {
- emake CC=$(tc-getCC) LD=$(tc-getCC)
+ emake CC=$(tc-getCC) LD=$(tc-getCC) MYLDFLAGS="${LDFLAGS}"
# Dereference symlinks
cd framework
mkdir lib.link
@@ -61,5 +59,6 @@ src_install() {
doins -r demo-app${subdir}
done
dodoc doc/*sample.conf libraries/mondelefant/example.lua
- dohtml doc/autodoc.html
+ docinto html
+ dodoc doc/autodoc.html
}