summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-08-11 23:29:49 +0000
committerYixun Lan <dlan@gentoo.org>2015-08-11 23:32:06 +0000
commita5b0c8e999abc7c2780b3e37023607bf79925a69 (patch)
treef8fdd39c9155c6f0317e8dcfc91c22d05b2135b2 /www-apps
parentsys-kernel/ck-sources: 4.1.5 version bump (diff)
downloadgentoo-a5b0c8e999abc7c2780b3e37023607bf79925a69.tar.gz
gentoo-a5b0c8e999abc7c2780b3e37023607bf79925a69.tar.bz2
gentoo-a5b0c8e999abc7c2780b3e37023607bf79925a69.zip
www-apps/joomla: bump 3.4.3, proxy for Harold Naparst
Package-Manager: portage-2.2.20
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/joomla/Manifest1
-rw-r--r--www-apps/joomla/joomla-3.4.3.ebuild51
-rw-r--r--www-apps/joomla/metadata.xml2
3 files changed, 53 insertions, 1 deletions
diff --git a/www-apps/joomla/Manifest b/www-apps/joomla/Manifest
index ee43319b268e..e55b2a4d9629 100644
--- a/www-apps/joomla/Manifest
+++ b/www-apps/joomla/Manifest
@@ -1 +1,2 @@
DIST Joomla_3.4.1-Stable-Full_Package.tar.bz2 6452772 SHA256 fc31a37e0b27072b410940657b5e06f0d7f75cd4ee1c3f4ae940623fec823842 SHA512 0b785fcb9f06cc294685e732cf18aeb6b2a7210b500586452650220b83f6bd68ec1c3d3c667b4ffbe95720d1454b21fdf4a3396ad0ab39b8c73c03b09af80a5d WHIRLPOOL 868a412bf2e7a6157fc9b2dfaecb7e3e9c2e2594658b844caa3675c4eaf4595da597b099d09252867527cc2d01b617ef7d80ae0ec2527ce6744a156eb89516cc
+DIST Joomla_3.4.3-Stable-Full_Package.tar.bz2 6334337 SHA256 a7aecfba6d9f753ca5307361fae478fb2736d84f4085e33d9dc6b64c1ff613b7 SHA512 6fdb9d773c5958347fb7e2e596d4dada1e762ecbd9ba05a8a6a0c1d7411f07d22b70529a44232f662b5765e1ded4d5e85e40da31badf55bb197bf8480febb1db WHIRLPOOL 713aa991219c37b4ef89a912b6a4794dcdae03161a2f2b929a0a1c7b69e5f2612186b2e599928d885b1cae887b2dacca4bf3e2ebc68d56a7be1b3e4c0f114a12
diff --git a/www-apps/joomla/joomla-3.4.3.ebuild b/www-apps/joomla/joomla-3.4.3.ebuild
new file mode 100644
index 000000000000..3e341293ad71
--- /dev/null
+++ b/www-apps/joomla/joomla-3.4.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit webapp versionator
+
+MY_PV=$(replace_version_separator '_' '-')
+
+DESCRIPTION="Joomla is a powerful Open Source Content Management System"
+HOMEPAGE="http://www.joomla.org/"
+SRC_URI="https://github.com/joomla/joomla-cms/releases/download/${MY_PV}/Joomla_${MY_PV}-Stable-Full_Package.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+S="${WORKDIR}"
+need_httpd_cgi
+
+DEPEND="${DEPEND}
+ app-arch/unzip"
+RDEPEND=">=dev-lang/php-5.3.10[json,zlib,xml]
+ virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[postgres] )"
+
+src_install () {
+ webapp_src_preinst
+
+ touch configuration.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files=" administrator/cache administrator/components
+ administrator/language administrator/language/en-GB
+ administrator/manifests/packages
+ administrator/modules administrator/templates cache components images installation
+ images/banners language language/en-GB media modules plugins
+ plugins/authentication plugins/content plugins/editors plugins/editors-xtd
+ plugins/search plugins/system plugins/user plugins tmp templates"
+
+ for file in ${files}; do
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postinst_txt sv "${FILESDIR}"/postinstall-sv.txt
+ webapp_src_install
+}
diff --git a/www-apps/joomla/metadata.xml b/www-apps/joomla/metadata.xml
index d0b641761e7e..9e95d7033246 100644
--- a/www-apps/joomla/metadata.xml
+++ b/www-apps/joomla/metadata.xml
@@ -4,7 +4,7 @@
<herd>web-apps</herd>
<herd>proxy-maintainers</herd>
<maintainer>
- <email>harold@alum.mit.edu</email>
+ <email>harold@naparst.com</email>
<name>Harold Naparst</name>
<description>Primary Maintainer, Assign bugs</description>
</maintainer>