summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-06-19 15:44:05 +1000
committerMatt Jolly <kangie@gentoo.org>2024-06-19 16:09:35 +1000
commit570cc96228ecc908cc41ab719d3415df05f5adfe (patch)
tree92797e90f3d33724b8c0a7151e5f97e0e7e2090d /www-client/dillo
parentdev-ruby/maxitest: drop 5.2.0, 5.3.1 (diff)
downloadgentoo-570cc96228ecc908cc41ab719d3415df05f5adfe.tar.gz
gentoo-570cc96228ecc908cc41ab719d3415df05f5adfe.tar.bz2
gentoo-570cc96228ecc908cc41ab719d3415df05f5adfe.zip
www-client/dillo: update xdg desxtup database
Closes: https://bugs.gentoo.org/933453 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client/dillo')
-rw-r--r--www-client/dillo/dillo-3.1.0.ebuild10
-rw-r--r--www-client/dillo/dillo-9999.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/www-client/dillo/dillo-3.1.0.ebuild b/www-client/dillo/dillo-3.1.0.ebuild
index 22187108639d..03aa65c4046e 100644
--- a/www-client/dillo/dillo-3.1.0.ebuild
+++ b/www-client/dillo/dillo-3.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools toolchain-funcs virtualx
+inherit autotools toolchain-funcs virtualx xdg-utils
DESCRIPTION="Lean FLTK based web browser"
HOMEPAGE="https://dillo-browser.github.io/"
@@ -104,3 +104,11 @@ src_install() {
use doc && dodoc -r html
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/www-client/dillo/dillo-9999.ebuild b/www-client/dillo/dillo-9999.ebuild
index dc06be8e2058..e1184d7c6667 100644
--- a/www-client/dillo/dillo-9999.ebuild
+++ b/www-client/dillo/dillo-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools toolchain-funcs virtualx
+inherit autotools toolchain-funcs virtualx xdg-utils
DESCRIPTION="Lean FLTK based web browser"
HOMEPAGE="https://dillo-browser.github.io/"
@@ -90,3 +90,11 @@ src_install() {
use doc && dodoc -r html
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}