summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-07 06:12:33 +0100
committerSam James <sam@gentoo.org>2023-04-07 06:12:33 +0100
commit5638c9b9103b86ad8264feff2b7edecd6e7d6c7f (patch)
tree6399c17d653a5977979cda742f057228deae4a07 /www-client/uget
parentnet-misc/curl: fix WhitespaceFound (diff)
downloadgentoo-5638c9b9103b86ad8264feff2b7edecd6e7d6c7f.tar.gz
gentoo-5638c9b9103b86ad8264feff2b7edecd6e7d6c7f.tar.bz2
gentoo-5638c9b9103b86ad8264feff2b7edecd6e7d6c7f.zip
www-client/uget: drop broken curl version check
This check can't handle curl >= 8 or non-bash /bin/sh. Closes: https://bugs.gentoo.org/872080 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/uget')
-rw-r--r--www-client/uget/files/uget-2.2.3-broken-curl-check.patch17
-rw-r--r--www-client/uget/uget-2.2.3.ebuild1
-rw-r--r--www-client/uget/uget-9999.ebuild1
3 files changed, 19 insertions, 0 deletions
diff --git a/www-client/uget/files/uget-2.2.3-broken-curl-check.patch b/www-client/uget/files/uget-2.2.3-broken-curl-check.patch
new file mode 100644
index 000000000000..c8e37abeca97
--- /dev/null
+++ b/www-client/uget/files/uget-2.2.3-broken-curl-check.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/872080
+
+This check can't handle curl >= 8 or non-bash /bin/sh.
+--- a/configure.ac
++++ b/configure.ac
+@@ -81,11 +81,6 @@ if test "x$CURL_CONFIG" = "x" ; then
+ fi
+ CURL_CFLAGS=`$CURL_CONFIG --cflags`
+ CURL_LIBS=`$CURL_CONFIG --libs`
+-let CURL_VERNUM=0x0`$CURL_CONFIG --vernum`
+-let CURL_VERMIN=0x071301 # 7.19.1
+-if test $CURL_VERNUM -lt $CURL_VERMIN; then
+- AC_MSG_ERROR(Requires libcurl version >= 7.19.1)
+-fi
+ AC_SUBST(CURL_CFLAGS)
+ AC_SUBST(CURL_LIBS)
+
diff --git a/www-client/uget/uget-2.2.3.ebuild b/www-client/uget/uget-2.2.3.ebuild
index b64f27cf31ef..7838c2e3a254 100644
--- a/www-client/uget/uget-2.2.3.ebuild
+++ b/www-client/uget/uget-2.2.3.ebuild
@@ -41,6 +41,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.2.1-fno-common.patch
# https://github.com/ugetdm/uget/issues/49
"${FILESDIR}"/${PN}-2.2.1-ayatana.patch
+ "${FILESDIR}"/${PN}-2.2.3-broken-curl-check.patch
)
src_prepare() {
diff --git a/www-client/uget/uget-9999.ebuild b/www-client/uget/uget-9999.ebuild
index bd1d745b7b0e..2fe8e367fbcf 100644
--- a/www-client/uget/uget-9999.ebuild
+++ b/www-client/uget/uget-9999.ebuild
@@ -38,6 +38,7 @@ BDEPEND="
PATCHES=(
# https://github.com/ugetdm/uget/issues/49
"${FILESDIR}"/${PN}-2.2.1-ayatana.patch
+ "${FILESDIR}"/${PN}-2.2.3-broken-curl-check.patch
)
src_prepare() {