summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/weboob
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/weboob')
-rw-r--r--www-client/weboob/Manifest2
-rw-r--r--www-client/weboob/metadata.xml12
-rw-r--r--www-client/weboob/weboob-0g.ebuild80
-rw-r--r--www-client/weboob/weboob-0h.ebuild80
-rw-r--r--www-client/weboob/weboob-9998.ebuild80
-rw-r--r--www-client/weboob/weboob-9999.ebuild80
6 files changed, 334 insertions, 0 deletions
diff --git a/www-client/weboob/Manifest b/www-client/weboob/Manifest
new file mode 100644
index 000000000000..80e534a60190
--- /dev/null
+++ b/www-client/weboob/Manifest
@@ -0,0 +1,2 @@
+DIST weboob-0.g.tar.gz 1465176 SHA256 ccf4643fa0573a905061b29603fc89ef9e953fa7d88c0d239807689c2eab5b2d SHA512 802b0f4cb10d1c2a13dc183d59aa642a9642b3b8f9417ce7bf66835a5f7028bc3fde9a8f3048b01cd5601585d37e6c95fa277b768723d05ab1b8eb4cb74a40bc WHIRLPOOL 4a42b4b48808f9590be1a4b0ab63cf79779905b9c4d789b24919241e85185bc07ace4a2cb8d6c34057ec86936828eeefc99e130ec4d9f7e507551340d3c86738
+DIST weboob-0.h.tar.gz 1700259 SHA256 070fe65d50ebac3901ec77b2062857be6a7174184d40634e50caefd1e5cb7ec2 SHA512 9ec34d184f965ec9124e7cb7e40e9337f781e2d79171fdc2f48b20d68bc21b8cabb349b56229b97f86257edb1d9f24886cbe3576a0fc80ed4440168119ea7e2b WHIRLPOOL 36e370ed0dd08a889dab58ea59903ed76168b689899811451a6add344b8fddbc433b7fa0b977db3b5f0c92dc5e6c7a26c8c664096e87b1f5c44cf8e40a0142ce
diff --git a/www-client/weboob/metadata.xml b/www-client/weboob/metadata.xml
new file mode 100644
index 000000000000..05b7d0179f07
--- /dev/null
+++ b/www-client/weboob/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <use>
+ <flag name="secure-updates">Enable secure updates</flag>
+ <flag name="fast-libs">Enable fast libs</flag>
+ </use>
+</pkgmetadata>
diff --git a/www-client/weboob/weboob-0g.ebuild b/www-client/weboob/weboob-0g.ebuild
new file mode 100644
index 000000000000..6da2649115ae
--- /dev/null
+++ b/www-client/weboob/weboob-0g.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils versionator
+
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/devel.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+elif [ "$PV" == "9998" ]; then
+ EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/stable.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~x86 ~amd64"
+ MY_P="${PN}-$(version_format_string '$1.$2')"
+ SRC_URI="http://symlink.me/attachments/download/229/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Weboob (Web Outside of Browsers) provides several applications to interact with a lot of websites"
+HOMEPAGE="http://weboob.org/"
+
+LICENSE="AGPL-3"
+SLOT="0"
+IUSE="X +secure-updates fast-libs"
+
+DEPEND="X? ( >=dev-python/PyQt4-4.9.4-r1[X,phonon,${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/html2text[${PYTHON_USEDEP}]
+ dev-python/mechanize[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/gdata[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ secure-updates? ( app-crypt/gnupg )
+ fast-libs? (
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/pyyaml[libyaml,${PYTHON_USEDEP}]
+ )
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS COPYING ChangeLog README INSTALL )
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(usex X '--qt' '--no-qt')
+ $(usex X '--xdg' '--no-xdg')
+ )
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${PN}/
+ doins -r contrib/*
+}
+
+pkg_preinst() {
+ use X && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use X && gnome2_icon_cache_update
+ elog 'You should now run "weboob-config update" (as your login user).'
+}
+
+pkg_postrm() {
+ use X && gnome2_icon_cache_update
+}
diff --git a/www-client/weboob/weboob-0h.ebuild b/www-client/weboob/weboob-0h.ebuild
new file mode 100644
index 000000000000..90fd7e99a287
--- /dev/null
+++ b/www-client/weboob/weboob-0h.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils versionator
+
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/devel.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+elif [ "$PV" == "9998" ]; then
+ EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/stable.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~x86 ~amd64"
+ MY_P="${PN}-$(version_format_string '$1.$2')"
+ SRC_URI="http://symlink.me/attachments/download/235/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Weboob (Web Outside of Browsers) provides several applications to interact with a lot of websites"
+HOMEPAGE="http://weboob.org/"
+
+LICENSE="AGPL-3"
+SLOT="0"
+IUSE="X +secure-updates fast-libs"
+
+DEPEND="X? ( >=dev-python/PyQt4-4.9.4-r1[X,phonon,${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/html2text[${PYTHON_USEDEP}]
+ dev-python/mechanize[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/gdata[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ secure-updates? ( app-crypt/gnupg )
+ fast-libs? (
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/pyyaml[libyaml,${PYTHON_USEDEP}]
+ )
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS COPYING ChangeLog README INSTALL )
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(usex X '--qt' '--no-qt')
+ $(usex X '--xdg' '--no-xdg')
+ )
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${PN}/
+ doins -r contrib/*
+}
+
+pkg_preinst() {
+ use X && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use X && gnome2_icon_cache_update
+ elog 'You should now run "weboob-config update" (as your login user).'
+}
+
+pkg_postrm() {
+ use X && gnome2_icon_cache_update
+}
diff --git a/www-client/weboob/weboob-9998.ebuild b/www-client/weboob/weboob-9998.ebuild
new file mode 100644
index 000000000000..6da2649115ae
--- /dev/null
+++ b/www-client/weboob/weboob-9998.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils versionator
+
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/devel.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+elif [ "$PV" == "9998" ]; then
+ EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/stable.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~x86 ~amd64"
+ MY_P="${PN}-$(version_format_string '$1.$2')"
+ SRC_URI="http://symlink.me/attachments/download/229/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Weboob (Web Outside of Browsers) provides several applications to interact with a lot of websites"
+HOMEPAGE="http://weboob.org/"
+
+LICENSE="AGPL-3"
+SLOT="0"
+IUSE="X +secure-updates fast-libs"
+
+DEPEND="X? ( >=dev-python/PyQt4-4.9.4-r1[X,phonon,${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/html2text[${PYTHON_USEDEP}]
+ dev-python/mechanize[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/gdata[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ secure-updates? ( app-crypt/gnupg )
+ fast-libs? (
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/pyyaml[libyaml,${PYTHON_USEDEP}]
+ )
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS COPYING ChangeLog README INSTALL )
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(usex X '--qt' '--no-qt')
+ $(usex X '--xdg' '--no-xdg')
+ )
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${PN}/
+ doins -r contrib/*
+}
+
+pkg_preinst() {
+ use X && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use X && gnome2_icon_cache_update
+ elog 'You should now run "weboob-config update" (as your login user).'
+}
+
+pkg_postrm() {
+ use X && gnome2_icon_cache_update
+}
diff --git a/www-client/weboob/weboob-9999.ebuild b/www-client/weboob/weboob-9999.ebuild
new file mode 100644
index 000000000000..6da2649115ae
--- /dev/null
+++ b/www-client/weboob/weboob-9999.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils versionator
+
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/devel.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+elif [ "$PV" == "9998" ]; then
+ EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/stable.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~x86 ~amd64"
+ MY_P="${PN}-$(version_format_string '$1.$2')"
+ SRC_URI="http://symlink.me/attachments/download/229/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Weboob (Web Outside of Browsers) provides several applications to interact with a lot of websites"
+HOMEPAGE="http://weboob.org/"
+
+LICENSE="AGPL-3"
+SLOT="0"
+IUSE="X +secure-updates fast-libs"
+
+DEPEND="X? ( >=dev-python/PyQt4-4.9.4-r1[X,phonon,${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/html2text[${PYTHON_USEDEP}]
+ dev-python/mechanize[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/gdata[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ secure-updates? ( app-crypt/gnupg )
+ fast-libs? (
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/pyyaml[libyaml,${PYTHON_USEDEP}]
+ )
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS COPYING ChangeLog README INSTALL )
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(usex X '--qt' '--no-qt')
+ $(usex X '--xdg' '--no-xdg')
+ )
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${PN}/
+ doins -r contrib/*
+}
+
+pkg_preinst() {
+ use X && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use X && gnome2_icon_cache_update
+ elog 'You should now run "weboob-config update" (as your login user).'
+}
+
+pkg_postrm() {
+ use X && gnome2_icon_cache_update
+}