summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-11-03 17:59:09 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-11-03 18:05:45 +0100
commitfe6afd3fadd8c6064ff0397cc5e20653d3a8caa9 (patch)
treea0546550f70cedeb8fae41f3f5a2147c8300080f /www-client
parentmail-client/thunderbird: bump to v91.3.0 (diff)
downloadgentoo-fe6afd3fadd8c6064ff0397cc5e20653d3a8caa9.tar.gz
gentoo-fe6afd3fadd8c6064ff0397cc5e20653d3a8caa9.tar.bz2
gentoo-fe6afd3fadd8c6064ff0397cc5e20653d3a8caa9.zip
www-client/firefox: sync with mail-client/thunderbird
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-91.3.0.ebuild83
-rw-r--r--www-client/firefox/firefox-94.0.ebuild84
2 files changed, 129 insertions, 38 deletions
diff --git a/www-client/firefox/firefox-91.3.0.ebuild b/www-client/firefox/firefox-91.3.0.ebuild
index 9b64305a6e44..6a93d263c454 100644
--- a/www-client/firefox/firefox-91.3.0.ebuild
+++ b/www-client/firefox/firefox-91.3.0.ebuild
@@ -48,7 +48,7 @@ if [[ ${PV} == *_rc* ]] ; then
fi
PATCH_URIS=(
- https://dev.gentoo.org/~{axs,polynomial-c,whissi}/mozilla/patchsets/${FIREFOX_PATCHSET}
+ https://dev.gentoo.org/~{polynomial-c,whissi}/mozilla/patchsets/${FIREFOX_PATCHSET}
)
SRC_URI="${MOZ_SRC_BASE_URI}/source/${MOZ_P}.source.tar.xz -> ${MOZ_P_DISTFILES}.source.tar.xz
@@ -61,15 +61,23 @@ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
SLOT="0/esr$(ver_cut 1)"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="+clang cpu_flags_arm_neon dbus debug eme-free geckodriver +gmp-autoupdate
- hardened hwaccel jack lto +openh264 pgo pulseaudio screencast sndio selinux
- +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent
- +system-libvpx +system-webp wayland wifi"
+
+IUSE="+clang cpu_flags_arm_neon dbus debug eme-free hardened hwaccel"
+IUSE+=" jack lto +openh264 pgo pulseaudio sndio selinux"
+IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx +system-webp"
+IUSE+=" wayland wifi"
+
+# Firefox-only IUSE
+IUSE+=" geckodriver"
+IUSE+=" +gmp-autoupdate"
+IUSE+=" screencast"
REQUIRED_USE="debug? ( !system-av1 )
- screencast? ( wayland )
wifi? ( dbus )"
+# Firefox-only REQUIRED_USE flags
+REQUIRED_USE+=" screencast? ( wayland )"
+
BDEPEND="${PYTHON_DEPS}
app-arch/unzip
app-arch/zip
@@ -227,15 +235,50 @@ llvm_check_deps() {
}
MOZ_LANGS=(
- ach af an ar ast az be bg bn br bs ca-valencia ca cak cs cy
- da de dsb el en-CA en-GB en-US eo es-AR es-CL es-ES es-MX et eu
- fa ff fi fr fy-NL ga-IE gd gl gn gu-IN he hi-IN hr hsb hu hy-AM
- ia id is it ja ka kab kk km kn ko lij lt lv mk mr ms my
- nb-NO ne-NP nl nn-NO oc pa-IN pl pt-BR pt-PT rm ro ru sco
- si sk sl son sq sr sv-SE szl ta te th tl tr trs uk ur uz vi
- xh zh-CN zh-TW
+ af ar ast be bg br ca cak cs cy da de dsb
+ el en-CA en-GB en-US es-AR es-ES et eu
+ fi fr fy-NL ga-IE gd gl he hr hsb hu
+ id is it ja ka kab kk ko lt lv ms nb-NO nl nn-NO
+ pa-IN pl pt-BR pt-PT rm ro ru
+ sk sl sq sr sv-SE th tr uk uz vi zh-CN zh-TW
)
+# Firefox-only LANGS
+MOZ_LANGS+=( ach )
+MOZ_LANGS+=( an )
+MOZ_LANGS+=( az )
+MOZ_LANGS+=( bn )
+MOZ_LANGS+=( bs )
+MOZ_LANGS+=( ca-valencia )
+MOZ_LANGS+=( eo )
+MOZ_LANGS+=( es-CL )
+MOZ_LANGS+=( es-MX )
+MOZ_LANGS+=( fa )
+MOZ_LANGS+=( ff )
+MOZ_LANGS+=( gn )
+MOZ_LANGS+=( gu-IN )
+MOZ_LANGS+=( hi-IN )
+MOZ_LANGS+=( hy-AM )
+MOZ_LANGS+=( ia )
+MOZ_LANGS+=( km )
+MOZ_LANGS+=( kn )
+MOZ_LANGS+=( lij )
+MOZ_LANGS+=( mk )
+MOZ_LANGS+=( mr )
+MOZ_LANGS+=( my )
+MOZ_LANGS+=( ne-NP )
+MOZ_LANGS+=( oc )
+MOZ_LANGS+=( sco )
+MOZ_LANGS+=( si )
+MOZ_LANGS+=( son )
+MOZ_LANGS+=( szl )
+MOZ_LANGS+=( ta )
+MOZ_LANGS+=( te )
+MOZ_LANGS+=( tl )
+MOZ_LANGS+=( trs )
+MOZ_LANGS+=( ur )
+MOZ_LANGS+=( xh )
+
mozilla_set_globals() {
# https://bugs.gentoo.org/587334
local MOZ_TOO_REGIONALIZED_FOR_L10N=(
@@ -961,9 +1004,9 @@ src_install() {
# Install system-wide preferences
local PREFS_DIR="${MOZILLA_FIVE_HOME}/browser/defaults/preferences"
insinto "${PREFS_DIR}"
- newins "${FILESDIR}"/gentoo-default-prefs.js all-gentoo.js
+ newins "${FILESDIR}"/gentoo-default-prefs.js gentoo-prefs.js
- local GENTOO_PREFS="${ED}${PREFS_DIR}/all-gentoo.js"
+ local GENTOO_PREFS="${ED}${PREFS_DIR}/gentoo-prefs.js"
# Set dictionary path to use system hunspell
cat >>"${GENTOO_PREFS}" <<-EOF || die "failed to set spellchecker.dictionary_path pref"
@@ -1108,7 +1151,9 @@ pkg_postinst() {
elog
fi
- local show_doh_information show_normandy_information show_shortcut_information
+ local show_doh_information
+ local show_normandy_information
+ local show_shortcut_information
if [[ -z "${REPLACING_VERSIONS}" ]] ; then
# New install; Tell user that DoH is disabled by default
@@ -1155,10 +1200,10 @@ pkg_postinst() {
if [[ -n "${show_shortcut_information}" ]] ; then
elog
- elog "Since firefox-91.0 we no longer install multiple shortcuts for"
+ elog "Since ${PN}-91.0 we no longer install multiple shortcuts for"
elog "each supported display protocol. Instead we will only install"
- elog "one generic Mozilla Firefox shortcut."
- elog "If you still want to be able to select between running Mozilla Firefox"
+ elog "one generic Mozilla ${PN^} shortcut."
+ elog "If you still want to be able to select between running Mozilla ${PN^}"
elog "on X11 or Wayland, you have to re-create these shortcuts on your own."
fi
}
diff --git a/www-client/firefox/firefox-94.0.ebuild b/www-client/firefox/firefox-94.0.ebuild
index 5c7cbe52269c..adbc1566ba3e 100644
--- a/www-client/firefox/firefox-94.0.ebuild
+++ b/www-client/firefox/firefox-94.0.ebuild
@@ -48,7 +48,7 @@ if [[ ${PV} == *_rc* ]] ; then
fi
PATCH_URIS=(
- https://dev.gentoo.org/~{axs,polynomial-c,whissi}/mozilla/patchsets/${FIREFOX_PATCHSET}
+ https://dev.gentoo.org/~{polynomial-c,whissi}/mozilla/patchsets/${FIREFOX_PATCHSET}
)
SRC_URI="${MOZ_SRC_BASE_URI}/source/${MOZ_P}.source.tar.xz -> ${MOZ_P_DISTFILES}.source.tar.xz
@@ -61,13 +61,22 @@ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
SLOT="0/$(ver_cut 1)"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="+clang cpu_flags_arm_neon dbus debug eme-free geckodriver +gmp-autoupdate
- hardened hwaccel jack lto +openh264 pgo pulseaudio screencast sndio selinux
- +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent
- +system-libvpx +system-webp wayland wifi"
+
+IUSE="+clang cpu_flags_arm_neon dbus debug eme-free hardened hwaccel"
+IUSE+=" jack lto +openh264 pgo pulseaudio sndio selinux"
+IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx +system-webp"
+IUSE+=" wayland wifi"
+
+# Firefox-only IUSE
+IUSE+=" geckodriver"
+IUSE+=" +gmp-autoupdate"
+IUSE+=" screencast"
REQUIRED_USE="debug? ( !system-av1 )
- screencast? ( wayland )"
+ wifi? ( dbus )"
+
+# Firefox-only REQUIRED_USE flags
+REQUIRED_USE+=" screencast? ( wayland )"
BDEPEND="${PYTHON_DEPS}
app-arch/unzip
@@ -226,15 +235,50 @@ llvm_check_deps() {
}
MOZ_LANGS=(
- ach af an ar ast az be bg bn br bs ca-valencia ca cak cs cy
- da de dsb el en-CA en-GB en-US eo es-AR es-CL es-ES es-MX et eu
- fa ff fi fr fy-NL ga-IE gd gl gn gu-IN he hi-IN hr hsb hu hy-AM
- ia id is it ja ka kab kk km kn ko lij lt lv mk mr ms my
- nb-NO ne-NP nl nn-NO oc pa-IN pl pt-BR pt-PT rm ro ru sco
- si sk sl son sq sr sv-SE szl ta te th tl tr trs uk ur uz vi
- xh zh-CN zh-TW
+ af ar ast be bg br ca cak cs cy da de dsb
+ el en-CA en-GB en-US es-AR es-ES et eu
+ fi fr fy-NL ga-IE gd gl he hr hsb hu
+ id is it ja ka kab kk ko lt lv ms nb-NO nl nn-NO
+ pa-IN pl pt-BR pt-PT rm ro ru
+ sk sl sq sr sv-SE th tr uk uz vi zh-CN zh-TW
)
+# Firefox-only LANGS
+MOZ_LANGS+=( ach )
+MOZ_LANGS+=( an )
+MOZ_LANGS+=( az )
+MOZ_LANGS+=( bn )
+MOZ_LANGS+=( bs )
+MOZ_LANGS+=( ca-valencia )
+MOZ_LANGS+=( eo )
+MOZ_LANGS+=( es-CL )
+MOZ_LANGS+=( es-MX )
+MOZ_LANGS+=( fa )
+MOZ_LANGS+=( ff )
+MOZ_LANGS+=( gn )
+MOZ_LANGS+=( gu-IN )
+MOZ_LANGS+=( hi-IN )
+MOZ_LANGS+=( hy-AM )
+MOZ_LANGS+=( ia )
+MOZ_LANGS+=( km )
+MOZ_LANGS+=( kn )
+MOZ_LANGS+=( lij )
+MOZ_LANGS+=( mk )
+MOZ_LANGS+=( mr )
+MOZ_LANGS+=( my )
+MOZ_LANGS+=( ne-NP )
+MOZ_LANGS+=( oc )
+MOZ_LANGS+=( sco )
+MOZ_LANGS+=( si )
+MOZ_LANGS+=( son )
+MOZ_LANGS+=( szl )
+MOZ_LANGS+=( ta )
+MOZ_LANGS+=( te )
+MOZ_LANGS+=( tl )
+MOZ_LANGS+=( trs )
+MOZ_LANGS+=( ur )
+MOZ_LANGS+=( xh )
+
mozilla_set_globals() {
# https://bugs.gentoo.org/587334
local MOZ_TOO_REGIONALIZED_FOR_L10N=(
@@ -960,9 +1004,9 @@ src_install() {
# Install system-wide preferences
local PREFS_DIR="${MOZILLA_FIVE_HOME}/browser/defaults/preferences"
insinto "${PREFS_DIR}"
- newins "${FILESDIR}"/gentoo-default-prefs.js all-gentoo.js
+ newins "${FILESDIR}"/gentoo-default-prefs.js gentoo-prefs.js
- local GENTOO_PREFS="${ED}${PREFS_DIR}/all-gentoo.js"
+ local GENTOO_PREFS="${ED}${PREFS_DIR}/gentoo-prefs.js"
# Set dictionary path to use system hunspell
cat >>"${GENTOO_PREFS}" <<-EOF || die "failed to set spellchecker.dictionary_path pref"
@@ -1107,7 +1151,9 @@ pkg_postinst() {
elog
fi
- local show_doh_information show_normandy_information show_shortcut_information
+ local show_doh_information
+ local show_normandy_information
+ local show_shortcut_information
if [[ -z "${REPLACING_VERSIONS}" ]] ; then
# New install; Tell user that DoH is disabled by default
@@ -1154,10 +1200,10 @@ pkg_postinst() {
if [[ -n "${show_shortcut_information}" ]] ; then
elog
- elog "Since firefox-91.0 we no longer install multiple shortcuts for"
+ elog "Since ${PN}-91.0 we no longer install multiple shortcuts for"
elog "each supported display protocol. Instead we will only install"
- elog "one generic Mozilla Firefox shortcut."
- elog "If you still want to be able to select between running Mozilla Firefox"
+ elog "one generic Mozilla ${PN^} shortcut."
+ elog "If you still want to be able to select between running Mozilla ${PN^}"
elog "on X11 or Wayland, you have to re-create these shortcuts on your own."
fi
}