summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-09-18 22:19:41 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-09-18 22:25:08 +0200
commit8d9427dfed80d6569efe05085d70e30d1936c57d (patch)
treed4ea423c2d2daffb254f2eb223e2a34c03c66d7e /www-servers/xsp
parentwww-servers/xsp: drop 3.8_p2014120900-r1 (diff)
downloadgentoo-8d9427dfed80d6569efe05085d70e30d1936c57d.tar.gz
gentoo-8d9427dfed80d6569efe05085d70e30d1936c57d.tar.bz2
gentoo-8d9427dfed80d6569efe05085d70e30d1936c57d.zip
www-servers/xsp: configuration and installation fixes
- correct configuration arguments for test and doc USE flags - remove unused developer USE flag - remove commented src_compile function - remove keepdir for /var/run/aspnet - update HOMEPAGE Closes: https://bugs.gentoo.org/628774 Closes: https://bugs.gentoo.org/634240 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'www-servers/xsp')
-rw-r--r--www-servers/xsp/xsp-4.7.1-r2.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/www-servers/xsp/xsp-4.7.1-r2.ebuild b/www-servers/xsp/xsp-4.7.1-r2.ebuild
new file mode 100644
index 000000000000..8a89773c5328
--- /dev/null
+++ b/www-servers/xsp/xsp-4.7.1-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_DOTNET="net35 net40 net45"
+inherit autotools dotnet systemd
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="https://www.mono-project.com/ASP.NET/"
+SRC_URI="https://github.com/mono/xsp/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-db/sqlite:3"
+RDEPEND="
+ ${DEPEND}
+ acct-group/aspnet
+ acct-user/aspnet
+"
+
+PATCHES=(
+ "${FILESDIR}/aclocal-fix.patch"
+)
+
+METAFILETOBUILD=xsp.sln
+
+src_prepare() {
+ default
+
+ eaclocal -I build/m4/shamrock -I build/m4/shave ${ACLOCAL_FLAGS}
+ if test -z "${NO_LIBTOOLIZE}" ; then
+ _elibtoolize --force --copy
+ fi
+
+ eautoconf
+ eautomake --gnu --add-missing --force --copy
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-maintainer-mode
+ $(use_with test unit-tests)
+ $(use_enable doc docs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ local PATCHDIR="${FILESDIR}/2.2/"
+
+ newinitd "${PATCHDIR}"/xsp.initd xsp
+ newinitd "${PATCHDIR}"/mod-mono-server-r1.initd mod-mono-server
+ newconfd "${PATCHDIR}"/xsp.confd xsp
+ newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server
+
+ insinto /etc/xsp4
+ doins "${FILESDIR}"/systemd/mono.webapp
+ insinto /etc/xsp4/conf.d
+
+ # mono-xsp4.service was original name from
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=770458;filename=mono-xsp4.service;att=1;msg=5
+ # I think that using the same commands as in debian
+ # systemctl start mono-xsp4.service
+ # systemctl start mono-xsp4
+ # is better than to have shorter command
+ # systemctl start xsp
+ #
+ # insinto /usr/lib/systemd/system
+ systemd_dounit "${FILESDIR}"/systemd/mono-xsp4.service
+}