summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-27 20:19:00 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-27 20:28:37 -0400
commita1500ec6d3258a2ca2f4d9319f092aab1eb3dfdc (patch)
tree1da42a09cfc3b8edc6e546461b02c57127c43e15 /x11-apps
parentdev-util/libabigail: forward ~ppc ~x86 (diff)
downloadgentoo-a1500ec6d3258a2ca2f4d9319f092aab1eb3dfdc.tar.gz
gentoo-a1500ec6d3258a2ca2f4d9319f092aab1eb3dfdc.tar.bz2
gentoo-a1500ec6d3258a2ca2f4d9319f092aab1eb3dfdc.zip
x11-apps/xdpyinfo: Version bump to 1.3.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xdpyinfo/Manifest1
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.3.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-apps/xdpyinfo/Manifest b/x11-apps/xdpyinfo/Manifest
index e9d098216406..84e9a735b880 100644
--- a/x11-apps/xdpyinfo/Manifest
+++ b/x11-apps/xdpyinfo/Manifest
@@ -1 +1,2 @@
DIST xdpyinfo-1.3.3.tar.xz 137088 BLAKE2B 8fdf49e65ac05ab27672ef2044044353f8bbfe0c8bf6135e71b9fbd45b3cb643f5794977802cbb7a44cfe9d20905b5e74b0cc41829c9fef837f32c81bb05ea2f SHA512 47fe0821bc64145876853712ebd7c0af80111c243813615b892429021cc9a53abd38c4684551ae300cb5a4eacdd3d26e2c93e789ed91a948b20e2c37cd2d2442
+DIST xdpyinfo-1.3.4.tar.xz 137064 BLAKE2B ea0e50d66c313e0f11164fe22cf9c46dcd9dafdcf0652895146a8f85e847e2f21ed2eb54f9512fd3a89657e44c6212b7c7de5359e304db660cfaa8c44a254356 SHA512 9ef9f5c10e15a40895e8f008896b960fdd438277657c7159d16f05db79cd2374cfaca4af2f4e59335824bfd2f74a045ef89dd99ea4130ed436ea59fbbb1cbe12
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.3.4.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.3.4.ebuild
new file mode 100644
index 000000000000..10be5df80d78
--- /dev/null
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.3.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="Display information utility for X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
+IUSE="dga dmx xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ dga? ( x11-libs/libXxf86dga )
+ dmx? ( x11-libs/libdmx )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --without-xf86misc
+ $(use_with dga)
+ $(use_with dmx)
+ $(use_with xinerama)
+ )
+ xorg-3_src_configure
+}