summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-12 15:13:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-12 20:37:22 +0100
commit80e2c3258708fd6c0626a1d9fa332a5ee68e0a61 (patch)
treeecab7fc8312869d544749d0603b654bbf7cfd089 /x11-libs/libfm-qt
parentmedia-sound/pavucontrol-qt: block 'lxqt-base/lxqt-l10n' (diff)
downloadgentoo-80e2c3258708fd6c0626a1d9fa332a5ee68e0a61.tar.gz
gentoo-80e2c3258708fd6c0626a1d9fa332a5ee68e0a61.tar.bz2
gentoo-80e2c3258708fd6c0626a1d9fa332a5ee68e0a61.zip
x11-libs/libfm-qt: remove 'x11-libs/libfm' dependency
Upstream removed this completely in 0.14.0. - https://github.com/lxqt/libfm-qt/blob/master/CHANGELOG#L25 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/11344 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-libs/libfm-qt')
-rw-r--r--x11-libs/libfm-qt/libfm-qt-0.14.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-libs/libfm-qt/libfm-qt-0.14.1-r1.ebuild b/x11-libs/libfm-qt/libfm-qt-0.14.1-r1.ebuild
new file mode 100644
index 000000000000..de820366ee64
--- /dev/null
+++ b/x11-libs/libfm-qt/libfm-qt-0.14.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Qt port of libfm, a library providing components to build desktop file managers"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/5"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=lxde-base/menu-cache-1.1.0
+ media-libs/libexif:=
+ x11-libs/libxcb:=
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"