summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-06-22 15:03:51 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-06-22 15:09:33 +0200
commitb4a20fe48d16cbbcb9d434b2b62317a4028b33e6 (patch)
tree9bf6165493e5ec519fb2249b81e7f7770e0e0899 /x11-misc/i3lock
parentdev-util/hip: fix build failure when git not installed (diff)
downloadgentoo-b4a20fe48d16cbbcb9d434b2b62317a4028b33e6.tar.gz
gentoo-b4a20fe48d16cbbcb9d434b2b62317a4028b33e6.tar.bz2
gentoo-b4a20fe48d16cbbcb9d434b2b62317a4028b33e6.zip
x11-misc/i3lock: add 2.14.1
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'x11-misc/i3lock')
-rw-r--r--x11-misc/i3lock/Manifest1
-rw-r--r--x11-misc/i3lock/i3lock-2.14.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/i3lock/Manifest b/x11-misc/i3lock/Manifest
index d9ea93d622f9..32786bdeef09 100644
--- a/x11-misc/i3lock/Manifest
+++ b/x11-misc/i3lock/Manifest
@@ -1,2 +1,3 @@
DIST i3lock-2.13.tar.bz2 149332 BLAKE2B 4b285fb3a27463f0d538d291134942a19933394c4c2d0acf27dfe5624a854cef0f29c5fc2e4ce4398c85ac0e6b774521c7daa65abedc0d38b0fd4897b2e6db88 SHA512 3a9bed3d14a2d59e641b3603448bb46d769104995b1c0239eca87d582e80e64dd8905b8e455bd5b0e635d4b37d7a87208d8de37253e9af799c65f4f8d396789d
+DIST i3lock-2.14.1.tar.xz 28756 BLAKE2B b38a3fafeebb5f8cebb643baeb875922659b556a5f919c2a837923e45e8f91a5f3ce297a424414ec9f05255e5888b91723617d837e5ffdbdf81aded42edc34cb SHA512 63b6bd73f66654fe52639434f7d3da64006144ec2ed685ba8683186730d4cc2c10d5aa66174f965030030243f59afaf6def3ff732f710ae441410218f84d6deb
DIST i3lock-2.14.tar.xz 28648 BLAKE2B ef315c4d1175a692b8ea2ac1a6a9cefdaa642fc28cfcc28cbf0c637f9d0cf0ea47738447cf0d90c3c2f869819c178a416aabc44dbfe93ab938e48da2a0143d0a SHA512 85f755333739e61a8ac90447410c48cf54345740bb6c6977efa88500e2b66dfd7fe3338e4fe38f817773219e5994ef6375010fdb3cf711e2ad42045874e39e20
diff --git a/x11-misc/i3lock/i3lock-2.14.1.ebuild b/x11-misc/i3lock/i3lock-2.14.1.ebuild
new file mode 100644
index 000000000000..ac578fdbe9af
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.14.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="https://i3wm.org/i3lock/"
+SRC_URI="https://i3wm.org/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/libev
+ sys-libs/pam
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-xrm"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:login:system-auth:g' pam/${PN} || die
+}