summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-19 17:07:19 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-19 18:34:49 -0400
commitc63ac82630728088e0f6c5c625291a1f845207f3 (patch)
tree459766831528328891ab6f1c931f36ff1aa9be0e /x11-misc/imake
parentapp-admin/ansible-lint: add 6.8.2, drop 6.8.1 (diff)
downloadgentoo-c63ac82630728088e0f6c5c625291a1f845207f3.tar.gz
gentoo-c63ac82630728088e0f6c5c625291a1f845207f3.tar.bz2
gentoo-c63ac82630728088e0f6c5c625291a1f845207f3.zip
x11-misc/imake: Version bump to 1.0.9
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc/imake')
-rw-r--r--x11-misc/imake/Manifest1
-rw-r--r--x11-misc/imake/files/imake-1.0.9-no-get-gcc.patch44
-rw-r--r--x11-misc/imake/imake-1.0.9.ebuild23
3 files changed, 68 insertions, 0 deletions
diff --git a/x11-misc/imake/Manifest b/x11-misc/imake/Manifest
index 766a015901e0..2973c18a9f1d 100644
--- a/x11-misc/imake/Manifest
+++ b/x11-misc/imake/Manifest
@@ -1 +1,2 @@
DIST imake-1.0.8.tar.bz2 159398 BLAKE2B 2ea03a06daab883a35ac4ef5c5598db89c84b2bbc41105902f64ffaf66a2e5cebaa28bef0ee7d258eb7279eaa95671b8798701423cafffe87d8feced5bc1b63d SHA512 5352b0148664506c8eb7ba80f95fced146d150398673547ba0b2c7c966a382bc21de43dfb8e0d74e38a0a563f16ddbec48bf8c8e6daa1a0899a95403579d7728
+DIST imake-1.0.9.tar.xz 153332 BLAKE2B d9de997016112833e50d1151448366c538b9796622630724552cc0476deed165621edc1a01318a83b577a85fcfc78b753e6fa9fbdf4c71413319abe542f1beca SHA512 e7587cf80369c8f4fcc1207c13bcb74a53d838b504ac8a7f3b98fb8f5f595cc7b8e5e9fad50cadcf40cf27bd02ef4eae7fe458854bbed7bea27d474d66520644
diff --git a/x11-misc/imake/files/imake-1.0.9-no-get-gcc.patch b/x11-misc/imake/files/imake-1.0.9-no-get-gcc.patch
new file mode 100644
index 000000000000..131b7978165b
--- /dev/null
+++ b/x11-misc/imake/files/imake-1.0.9-no-get-gcc.patch
@@ -0,0 +1,44 @@
+If /usr/bin/cc exists then get_gcc() is always true on Linux (and many
+others), but will fail in the event it's missing (-native-symlinks).
+
+get_gcc_version does not execute gcc and merely sets defines, so
+call it without using get_gcc(). Validity of using NULL should be
+verified if there's ever a new version.
+--- a/imake.c
++++ b/imake.c
+@@ -1331,6 +1331,7 @@ get_gcc_version(FILE *inFile, char *name)
+ }
+ #endif
+
++#if defined CROSSCOMPILE
+ static boolean
+ get_gcc(char *cmd)
+ {
+@@ -1384,7 +1385,6 @@ get_gcc(char *cmd)
+ return FALSE;
+ }
+
+-#ifdef CROSSCOMPILE
+ static void
+ get_gcc_incdir(FILE *inFile, char* name)
+ {
+@@ -1630,14 +1630,16 @@ define_os_defaults(FILE *inFile)
+ if (gnu_c)
+ # endif
+ {
++# if defined CROSSCOMPILE
+ char gcc_name[PATH_MAX];
+ if (get_gcc(gcc_name)) {
+ get_gcc_version (inFile, gcc_name);
+-# if defined CROSSCOMPILE
+ if (sys != emx)
+ get_gcc_incdir(inFile, gcc_name);
+-# endif
+ }
++# else
++ get_gcc_version(inFile,NULL);
++# endif
+ }
+ # endif
+ # if defined __FreeBSD__
+--
diff --git a/x11-misc/imake/imake-1.0.9.ebuild b/x11-misc/imake/imake-1.0.9.ebuild
new file mode 100644
index 000000000000..90e00308d59d
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+inherit toolchain-funcs xorg-3
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.8-cpp-args.patch
+ "${FILESDIR}"/${PN}-1.0.9-no-get-gcc.patch
+ "${FILESDIR}"/${PN}-1.0.8-respect-LD.patch
+ "${FILESDIR}"/${PN}-1.0.8-xmkmf-pass-cc-ld.patch
+)
+
+src_configure() {
+ econf CPP="$(tc-getPROG CPP cpp)" #722046
+}