summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/mate-notification-daemon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/mate-notification-daemon')
-rw-r--r--x11-misc/mate-notification-daemon/Manifest2
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.8.0.ebuild58
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.8.1.ebuild58
-rw-r--r--x11-misc/mate-notification-daemon/metadata.xml8
4 files changed, 126 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/Manifest b/x11-misc/mate-notification-daemon/Manifest
new file mode 100644
index 000000000000..7cd357b12949
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/Manifest
@@ -0,0 +1,2 @@
+DIST mate-notification-daemon-1.8.0.tar.xz 301228 SHA256 21f29513efdbc97ab87e7813bb81c2d23038f5c49a57f55107316f99ae79cfb0 SHA512 a37fe85998b18148eb1dcf4f96a6a18a8f2b9acdbeaf356decc41b220e8db58db914cd1f2ff665081061e63119773445d9fb874c19ab8fd5396fc7b927f6267d WHIRLPOOL fc7a093b558745bcceee708fdf6ad24df41ebbc2beebc41b742b59e7ef1b2c9b59a9daea4166c7713264e5a2c804e63e5f9bf17aadaba718c1e94a3977a55744
+DIST mate-notification-daemon-1.8.1.tar.xz 300984 SHA256 322b0f461d0972536916191481ee8f71b94c9534049498617c78218c9ce792a6 SHA512 45d9d8e95628a4ea384335a2293c85cda3177676acf6b4d3ee877f85f7b631c8f19429884017414f6882c4b6dcb32a1c2dbeb3bebaee8f8ab3107003bf3c9d92 WHIRLPOOL 4c88feacefd6e1f5b741e19694f8c17e83ff0963340b4f6a90bec07d532608e39ad617f41d5301e703dc3c3326021062edd748a44899e61905cabd1173b86120
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.8.0.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.8.0.ebuild
new file mode 100644
index 000000000000..54df139aa68a
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.8.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE Notification daemon"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.78:0
+ >=dev-libs/glib-2.18:2
+ >=media-libs/libcanberra-0.4:0[gtk]
+ >=sys-apps/dbus-1:0
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.18:2
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/libX11:0
+ >=x11-libs/libwnck-1:1
+ virtual/libintl:0
+ !x11-misc/notify-osd:*
+ !x11-misc/qtnotifydaemon:*
+ !x11-misc/notification-daemon:*"
+
+DEPEND="${RDEPEND}
+ app-arch/xz-utils:0
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_install() {
+ gnome2_src_install
+
+ cat <<-EOF > "${T}/org.freedesktop.Notifications.service"
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=/usr/libexec/mate-notification-daemon
+ EOF
+
+ insinto /usr/share/dbus-1/services
+ doins "${T}/org.freedesktop.Notifications.service"
+}
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.8.1.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.8.1.ebuild
new file mode 100644
index 000000000000..149190eefe3e
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.8.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE Notification daemon"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.78:0
+ >=dev-libs/glib-2.18:2
+ >=media-libs/libcanberra-0.4:0[gtk]
+ >=sys-apps/dbus-1:0
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.18:2
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/libX11:0
+ >=x11-libs/libwnck-1:1
+ virtual/libintl:0
+ !x11-misc/notify-osd:*
+ !x11-misc/qtnotifydaemon:*
+ !x11-misc/notification-daemon:*"
+
+DEPEND="${RDEPEND}
+ app-arch/xz-utils:0
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_install() {
+ gnome2_src_install
+
+ cat <<-EOF > "${T}/org.freedesktop.Notifications.service"
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=/usr/libexec/mate-notification-daemon
+ EOF
+
+ insinto /usr/share/dbus-1/services
+ doins "${T}/org.freedesktop.Notifications.service"
+}
diff --git a/x11-misc/mate-notification-daemon/metadata.xml b/x11-misc/mate-notification-daemon/metadata.xml
new file mode 100644
index 000000000000..504b80a3baa5
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <upstream>
+ <remote-id type="github">mate-desktop/mate-notification-daemon</remote-id>
+ </upstream>
+</pkgmetadata>