summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /x11-misc/shutter
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc/shutter')
-rw-r--r--x11-misc/shutter/shutter-0.93.1-r3.ebuild12
-rw-r--r--x11-misc/shutter/shutter-0.94.3.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/x11-misc/shutter/shutter-0.93.1-r3.ebuild b/x11-misc/shutter/shutter-0.93.1-r3.ebuild
index 56732b72603c..e16c4a878a4e 100644
--- a/x11-misc/shutter/shutter-0.93.1-r3.ebuild
+++ b/x11-misc/shutter/shutter-0.93.1-r3.ebuild
@@ -54,18 +54,18 @@ src_prepare() {
}
src_install() {
- dobin bin/${PN} || die "dobin failed"
+ dobin bin/${PN}
insinto /usr/share/${PN}
- doins -r share/${PN}/* || die "doins failed"
- dodoc README || die "dodoc failed"
+ doins -r share/${PN}/*
+ dodoc README
domenu share/applications/${PN}.desktop
# Man page is broken. Reconstruct it.
gunzip share/man/man1/${PN}.1.gz || die "gunzip failed"
- doman share/man/man1/${PN}.1 || die "doman failed"
+ doman share/man/man1/${PN}.1
doicon share/pixmaps/${PN}.png
- doins -r share/locale || die "doins failed"
+ doins -r share/locale
insinto /usr/share/icons/hicolor
- doins -r share/icons/hicolor/* || die "doins failed"
+ doins -r share/icons/hicolor/*
find "${D}"/usr/share/shutter/resources/system/plugins/ -type f ! -name '*.*' -exec chmod 755 {} \; \
|| die "failed to make plugins executables"
find "${D}"/usr/share/shutter/resources/system/upload_plugins/upload -type f \
diff --git a/x11-misc/shutter/shutter-0.94.3.ebuild b/x11-misc/shutter/shutter-0.94.3.ebuild
index 1bdd2fcc248d..18f36792dd4b 100644
--- a/x11-misc/shutter/shutter-0.94.3.ebuild
+++ b/x11-misc/shutter/shutter-0.94.3.ebuild
@@ -51,18 +51,18 @@ src_prepare() {
}
src_install() {
- dobin bin/${PN} || die "dobin failed"
+ dobin bin/${PN}
insinto /usr/share/${PN}
- doins -r share/${PN}/* || die "doins failed"
- dodoc README || die "dodoc failed"
+ doins -r share/${PN}/*
+ dodoc README
domenu share/applications/${PN}.desktop
# Man page is broken. Reconstruct it.
gunzip share/man/man1/${PN}.1.gz || die "gunzip failed"
- doman share/man/man1/${PN}.1 || die "doman failed"
+ doman share/man/man1/${PN}.1
doicon share/pixmaps/${PN}.png
- doins -r share/locale || die "doins failed"
+ doins -r share/locale
insinto /usr/share/icons/hicolor
- doins -r share/icons/hicolor/* || die "doins failed"
+ doins -r share/icons/hicolor/*
find "${D}"/usr/share/shutter/resources/system/plugins/ -type f ! -name '*.*' -exec chmod 755 {} \; \
|| die "failed to make plugins executables"
find "${D}"/usr/share/shutter/resources/system/upload_plugins/upload -type f \