summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/tint2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/tint2')
-rw-r--r--x11-misc/tint2/Manifest1
-rw-r--r--x11-misc/tint2/files/battery_segfault.patch20
-rw-r--r--x11-misc/tint2/metadata.xml20
-rw-r--r--x11-misc/tint2/tint2-0.11-r1.ebuild58
-rw-r--r--x11-misc/tint2/tint2-0.11-r2.ebuild56
5 files changed, 155 insertions, 0 deletions
diff --git a/x11-misc/tint2/Manifest b/x11-misc/tint2/Manifest
new file mode 100644
index 000000000000..d76be0515621
--- /dev/null
+++ b/x11-misc/tint2/Manifest
@@ -0,0 +1 @@
+DIST tint2-0.11.tar.bz2 91716 SHA256 fe106e6a6057d2631abddde9f82d3fd4fb1985c4fb93f10d3886417a9e22471d SHA512 db88c17780d24b82badbedbce4518d736dfcb2a730ff500bcb36f2b32f65271c2424f0c2a34981f9d3af033b84252db0c8217e2dd7ca57f9a0eadbc98796115c WHIRLPOOL 4c497995bc5713199a8e624ebfa463edbd610b6d948f1cbfce11ec78e4cd2cd6fad51bd58937b0fce343bb86a29a35bc40eec2bafb687c6ee89355bceb5486ec
diff --git a/x11-misc/tint2/files/battery_segfault.patch b/x11-misc/tint2/files/battery_segfault.patch
new file mode 100644
index 000000000000..3f933e2f5223
--- /dev/null
+++ b/x11-misc/tint2/files/battery_segfault.patch
@@ -0,0 +1,20 @@
+Index: battery.c
+===================================================================
+--- src/battery/battery.c (revision 575)
++++ src/battery/battery.c (revision 576)
+@@ -194,8 +194,14 @@
+ }
+ g_free(path2);
+ }
++
++ path_current_now = g_build_filename(battery_dir, "power_now", NULL);
++ if (!g_file_test (path_current_now, G_FILE_TEST_EXISTS)) {
++ g_free(path_current_now);
++ path_current_now = g_build_filename(battery_dir, "current_now", NULL);
++ }
++
+ if (path_energy_now && path_energy_full) {
+- path_current_now = g_build_filename(battery_dir, "current_now", NULL);
+ path_status = g_build_filename(battery_dir, "status", NULL);
+
+ // check file
diff --git a/x11-misc/tint2/metadata.xml b/x11-misc/tint2/metadata.xml
new file mode 100644
index 000000000000..1531b9302030
--- /dev/null
+++ b/x11-misc/tint2/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>amynka@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="examples">Install tint2rc examples</flag>
+ <flag name="battery">Enable battery status plugin</flag>
+ <flag name="tint2conf">Build/Install tint2conf as well</flag>
+ </use>
+ <longdescription lang="en">tint2 is a simple panel/taskbar intentionally made for
+ <pkg>
+ openbox</pkg>3, but should also work with other window managers.
+ It's based on ttm code http://code.google.com/p/ttm/.
+ The goal is to keep a clean and unintrusive look with code lightweight and compliance with freedesktop specifications.</longdescription>
+ <upstream>
+ <remote-id type="google-code">tint2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/tint2/tint2-0.11-r1.ebuild b/x11-misc/tint2/tint2-0.11-r1.ebuild
new file mode 100644
index 000000000000..175f52218cf5
--- /dev/null
+++ b/x11-misc/tint2/tint2-0.11-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit cmake-utils eutils
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="A lightweight panel/taskbar"
+HOMEPAGE="https://gitlab.com/o9000/tint2"
+SRC_URI="http://tint2.googlecode.com/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="battery examples tint2conf"
+
+COMMON_DEPEND="dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/pango[X]
+ x11-libs/libX11
+ x11-libs/libXinerama
+ x11-libs/libXdamage
+ x11-libs/libXcomposite
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ media-libs/imlib2[X]"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto"
+RDEPEND="${COMMON_DEPEND}
+ tint2conf? ( x11-misc/tintwizard )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/battery_segfault.patch" # bug 343963
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable battery BATTERY)
+ $(cmake-utils_use_enable examples EXAMPLES)
+ $(cmake-utils_use_enable tint2conf TINT2CONF)
+
+ # bug 296890
+ "-DDOCDIR=/usr/share/doc/${PF}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -f "${D}/usr/bin/tintwizard.py"
+}
diff --git a/x11-misc/tint2/tint2-0.11-r2.ebuild b/x11-misc/tint2/tint2-0.11-r2.ebuild
new file mode 100644
index 000000000000..bc4d1377738d
--- /dev/null
+++ b/x11-misc/tint2/tint2-0.11-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit cmake-utils
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="A lightweight panel/taskbar"
+HOMEPAGE="https://gitlab.com/o9000/tint2"
+SRC_URI="http://tint2.googlecode.com/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="battery examples tint2conf"
+
+COMMON_DEPEND="dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/pango[X]
+ x11-libs/libX11
+ x11-libs/libXinerama
+ x11-libs/libXdamage
+ x11-libs/libXcomposite
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ media-libs/imlib2[X]"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto"
+RDEPEND="${COMMON_DEPEND}
+ tint2conf? ( x11-misc/tintwizard )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/battery_segfault.patch" ) # bug 343963
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable battery BATTERY)
+ $(cmake-utils_use_enable examples EXAMPLES)
+ $(cmake-utils_use_enable tint2conf TINT2CONF)
+
+ # bug 296890
+ "-DDOCDIR=/usr/share/doc/${PF}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -f "${D}/usr/bin/tintwizard.py"
+}