summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/compiz-plugins-main
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/compiz-plugins-main')
-rw-r--r--x11-plugins/compiz-plugins-main/Manifest1
-rw-r--r--x11-plugins/compiz-plugins-main/compiz-plugins-main-0.8.8.ebuild61
-rw-r--r--x11-plugins/compiz-plugins-main/files/compiz-plugins-main-no-gconf.patch22
-rw-r--r--x11-plugins/compiz-plugins-main/metadata.xml16
4 files changed, 100 insertions, 0 deletions
diff --git a/x11-plugins/compiz-plugins-main/Manifest b/x11-plugins/compiz-plugins-main/Manifest
new file mode 100644
index 000000000000..ba5e102d194c
--- /dev/null
+++ b/x11-plugins/compiz-plugins-main/Manifest
@@ -0,0 +1 @@
+DIST compiz-plugins-main-0.8.8.tar.bz2 1230627 SHA256 c79278b5369660d6274661a2c196f1cb016ef2b5d34e30bd18dbaeb241bee248
diff --git a/x11-plugins/compiz-plugins-main/compiz-plugins-main-0.8.8.ebuild b/x11-plugins/compiz-plugins-main/compiz-plugins-main-0.8.8.ebuild
new file mode 100644
index 000000000000..9b65014dd9ba
--- /dev/null
+++ b/x11-plugins/compiz-plugins-main/compiz-plugins-main-0.8.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="Compiz Fusion Window Decorator Plugins"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gconf"
+
+RDEPEND="
+ >=gnome-base/librsvg-2.14.0:2
+ x11-libs/cairo
+ >=x11-libs/compiz-bcop-${PV}
+ >=x11-wm/compiz-${PV}[gconf?]
+ virtual/jpeg:0
+ virtual/glu
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.15
+ gconf? ( gnome-base/gconf:2 )
+"
+
+DOCS="AUTHORS ChangeLog INSTALL NEWS README TODO"
+
+src_prepare() {
+ if ! use gconf; then
+ epatch "${FILESDIR}"/${PN}-no-gconf.patch
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-fast-install \
+ --disable-static \
+ $(use_enable gconf schemas)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
+
+pkg_preinst() {
+ use gconf && gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ use gconf && gnome2_gconf_install
+}
diff --git a/x11-plugins/compiz-plugins-main/files/compiz-plugins-main-no-gconf.patch b/x11-plugins/compiz-plugins-main/files/compiz-plugins-main-no-gconf.patch
new file mode 100644
index 000000000000..63222a5f1ce6
--- /dev/null
+++ b/x11-plugins/compiz-plugins-main/files/compiz-plugins-main-no-gconf.patch
@@ -0,0 +1,22 @@
+ configure.ac | 5 ++---
+ 1 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 297a8cf..290e92b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -171,11 +171,10 @@
+ if test x"$use_schemas" = x"yes"; then
+ fi
+ xsltdir=`$PKG_CONFIG --variable=xsltdir compiz-gconf`
+ AC_SUBST(xsltdir)
++else
++ AM_CONDITIONAL(GCONF_SCHEMAS_INSTALL, test "x$use_gconf" = "xyes")
+ fi
+
+-AM_GCONF_SOURCE_2
+-
+-
+ AM_CONDITIONAL(USE_SCHEMAS, test "x$use_schemas" = "xyes")
+ if test "$use_schemas" = yes; then
+ AC_DEFINE(USE_SCHEMAS, 1, [Build gconf schemas])
diff --git a/x11-plugins/compiz-plugins-main/metadata.xml b/x11-plugins/compiz-plugins-main/metadata.xml
new file mode 100644
index 000000000000..f80d46d0455f
--- /dev/null
+++ b/x11-plugins/compiz-plugins-main/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-effects</herd>
+<longdescription lang="en">
+Package with the base compiz-fusion plugins:
+animation, colourfilter, expo, ezoom, jpeg, neg, opacify, put, resizeinfo, ring,
+scaleaddon, shift, snap, text, thumbnail, vpswitch,, wall, winrules, workarounds.
+</longdescription>
+ <use>
+ <flag name="gconf">
+ Install GConf schemas for the plugins, needed when using the GConf-based
+ configuration backend in <pkg>x11-wm/compiz</pkg>.
+ </flag>
+ </use>
+</pkgmetadata>