summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmmp3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmmp3')
-rw-r--r--x11-plugins/wmmp3/Manifest1
-rw-r--r--x11-plugins/wmmp3/files/wmmp3-0.12-x_includes_n_libraries.patch20
-rw-r--r--x11-plugins/wmmp3/metadata.xml5
-rw-r--r--x11-plugins/wmmp3/wmmp3-0.12.ebuild45
4 files changed, 71 insertions, 0 deletions
diff --git a/x11-plugins/wmmp3/Manifest b/x11-plugins/wmmp3/Manifest
new file mode 100644
index 000000000000..12ca2067d3a2
--- /dev/null
+++ b/x11-plugins/wmmp3/Manifest
@@ -0,0 +1 @@
+DIST wmmp3-0.12.tar.gz 43977 SHA256 babbb158f83befd0e8eab9d794c8353ea536a477cb8b3e500be389cf658941c3 SHA512 6cc06f109d6ab6c69ed3b8175010a2f38053138291f02e59780fc7394c35cc629ddd6b982bd5069e20a3cb81d81b3d08b9e10d1f7984f783f22c9b012c933740 WHIRLPOOL c8199106c502c5c2bea9f5e2c981bd96720bce607d3714c8a91b289d1c708b76a4315338c6cbec0a8340bdca3d1e9ebb1b2d3214a90e58140864eca1aa155a31
diff --git a/x11-plugins/wmmp3/files/wmmp3-0.12-x_includes_n_libraries.patch b/x11-plugins/wmmp3/files/wmmp3-0.12-x_includes_n_libraries.patch
new file mode 100644
index 000000000000..91e6c679dcda
--- /dev/null
+++ b/x11-plugins/wmmp3/files/wmmp3-0.12-x_includes_n_libraries.patch
@@ -0,0 +1,20 @@
+--- configure.orig 2005-08-24 09:45:23.000000000 +0200
++++ configure 2005-08-24 09:45:08.000000000 +0200
+@@ -1977,11 +1977,15 @@
+
+
+ if test "$x_includes" != "NONE"; then
+- CFLAGS="$CFLAGS -I$x_includes"
++ if test "$x_includes" != ""; then
++ CFLAGS="$CFLAGS -I$x_includes"
++ fi
+ fi
+
+ if test "$x_libraries" != "NONE"; then
+- LDFLAGS="$LDFLAGS -L$x_libraries"
++ if test "$x_libraries" != ""; then
++ LDFLAGS="$LDFLAGS -L$x_libraries"
++ fi
+ fi
+
+ echo $ac_n "checking for XOpenDisplay in -lX11""... $ac_c" 1>&6
diff --git a/x11-plugins/wmmp3/metadata.xml b/x11-plugins/wmmp3/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmmp3/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmmp3/wmmp3-0.12.ebuild b/x11-plugins/wmmp3/wmmp3-0.12.ebuild
new file mode 100644
index 000000000000..91e9f61c6671
--- /dev/null
+++ b/x11-plugins/wmmp3/wmmp3-0.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Mp3 player dock app for WindowMaker; frontend to mpg123"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/60"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/91/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc sparc x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ media-sound/mpg123"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix #103531
+ epatch "${FILESDIR}"/${P}-x_includes_n_libraries.patch
+}
+
+src_compile() {
+ # override wmmp3 self-calculated cflags
+ econf
+ emake prefix="/usr/" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog sample.wmmp3 README TODO
+}
+
+pkg_postinst() {
+ einfo "Please copy the sample.wmmp3 to your home directory and change it to fit your needs."
+}