summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-04-08 09:12:23 +0200
committerSam James <sam@gentoo.org>2022-04-21 20:54:42 +0100
commit00aaa1e2f3d6a8de802e3a450efd7d904b3a29ea (patch)
tree13dcd49a428cbe0467d8a928ce3c5b5bd8f01031 /x11-plugins
parentx11-plugins/gkrellstock: update EAPI 6 -> 8 (diff)
downloadgentoo-00aaa1e2f3d6a8de802e3a450efd7d904b3a29ea.tar.gz
gentoo-00aaa1e2f3d6a8de802e3a450efd7d904b3a29ea.tar.bz2
gentoo-00aaa1e2f3d6a8de802e3a450efd7d904b3a29ea.zip
x11-plugins/gkrellmss: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/742914 Closes: https://bugs.gentoo.org/834951 Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellmss/files/gkrellmss-2.6-r5-configure-makefile-fixes.patch61
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6-r5.ebuild37
2 files changed, 98 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmss/files/gkrellmss-2.6-r5-configure-makefile-fixes.patch b/x11-plugins/gkrellmss/files/gkrellmss-2.6-r5-configure-makefile-fixes.patch
new file mode 100644
index 000000000000..a3eeae49cd56
--- /dev/null
+++ b/x11-plugins/gkrellmss/files/gkrellmss-2.6-r5-configure-makefile-fixes.patch
@@ -0,0 +1,61 @@
+Respect the user's pkg-config, don't call cc directly, respect CFLAGS
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -7,9 +7,9 @@ endif
+ INSTALLDIR ?= $(INSTALLROOT)/lib/gkrellm2/plugins
+ INSTALL ?= install
+
+-
+-GTK_INCLUDE = `pkg-config gtk+-2.0 --cflags`
+-GTK_LIB = `pkg-config gtk+-2.0 --libs`
++PKG_CONFIG ?= pkg-config
++GTK_INCLUDE = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK_LIB = $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
+
+ OS_NAME=$(shell uname -s)
+
+@@ -92,7 +92,7 @@ ifeq ($(alsa),1)
+ FLAGS += -DGKRELLM_ALSA
+ endif
+
+-CC = gcc $(FLAGS) $(CFLAGS)
++CC = $(CC)
+
+ OBJS = gkrellmss.o oscope.o spectrum.o sdlib.o option.o
+
+@@ -101,7 +101,7 @@ all: gkrellmss.so
+ warn: ; $(WARN)
+
+ gkrellmss.so: $(OBJS) warn
+- $(CC) $(OBJS) -o gkrellmss.so $(LFLAGS) $(LIBS)
++ $(CC) $(FLAGS) $(CFLAGS) $(OBJS) -o gkrellmss.so $(LFLAGS) $(LIBS)
+
+
+ clean:
+@@ -121,7 +121,12 @@ help:
+ @echo ""
+
+ gkrellmss.o: gkrellmss.c gkrellmss.h configure
++ $(CC) $(CFLAGS) $(FLAGS) -c -o $@ $<
+ oscope.o: oscope.c gkrellmss.h configure
++ $(CC) $(CFLAGS) $(FLAGS) -c -o $@ $<
+ spectrum.o: spectrum.c gkrellmss.h configure
++ $(CC) $(CFLAGS) $(FLAGS) -c -o $@ $<
+ sdlib.o: sdlib.c gkrellmss.h sdlib-esd.c sdlib-alsa.c configure
++ $(CC) $(CFLAGS) $(FLAGS) -c -o $@ $<
+ option.o: option.c gkrellmss.h configure
++ $(CC) $(CFLAGS) $(FLAGS) -c -o $@ $<
+--- a/src/configure
++++ b/src/configure
+@@ -18,8 +18,9 @@ do
+ done
+
+
+-PKG_INCLUDE=`pkg-config gtk+-2.0 --cflags`
+-PKG_LIB=`pkg-config gtk+-2.0 --libs`
++PKG_CONFIG=${PKG_CONFIG-pkg-config}
++PKG_INCLUDE=$(${PKG_CONFIG} gtk+-2.0 --cflags)
++PKG_LIB=$(${PKG_CONFIG} gtk+-2.0 --libs)
+
+ rm -f configure.h configure.log test test.o test.c
+
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6-r5.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6-r5.ebuild
new file mode 100644
index 000000000000..33ca3455e91c
--- /dev/null
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6-r5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin
+
+DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
+HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
+SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ media-libs/alsa-lib
+ sci-libs/fftw:3.0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Respect-LDFLAGS.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-r5-configure-makefile-fixes.patch
+)
+
+PLUGIN_DOCS=( Themes )
+
+src_compile() {
+ tc-export PKG_CONFIG
+ PLUGIN_SO=( src/gkrellmss$(get_modname) )
+ addpredict /dev/snd
+ emake CC="$(tc-getCC)" enable_nls=$(usex nls 1 0) without-esd=yes
+}