summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-05-08 19:18:42 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-05-09 00:54:14 +0200
commit189b59c8a00387da620965e5527fe3a9ba1d8b9f (patch)
treecf49a9ff7560e685c5809313c124380c46d4420a /x11-plugins
parentdev-php/pecl-zmq: subscribe to net-libs/czmq subslot (diff)
downloadgentoo-189b59c8a00387da620965e5527fe3a9ba1d8b9f.tar.gz
gentoo-189b59c8a00387da620965e5527fe3a9ba1d8b9f.tar.bz2
gentoo-189b59c8a00387da620965e5527fe3a9ba1d8b9f.zip
x11-plugins/wmmp3: fix build with -fno-common
Closes: https://bugs.gentoo.org/710114 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmp3/files/wmmp3-0.12-fno-common.patch33
-rw-r--r--x11-plugins/wmmp3/wmmp3-0.12-r1.ebuild6
2 files changed, 37 insertions, 2 deletions
diff --git a/x11-plugins/wmmp3/files/wmmp3-0.12-fno-common.patch b/x11-plugins/wmmp3/files/wmmp3-0.12-fno-common.patch
new file mode 100644
index 000000000000..2179b9e30dd2
--- /dev/null
+++ b/x11-plugins/wmmp3/files/wmmp3-0.12-fno-common.patch
@@ -0,0 +1,33 @@
+diff -Naur wmmp3-0.12.orig/wmgeneral.c wmmp3-0.12/wmgeneral.c
+--- wmmp3-0.12.orig/wmgeneral.c 1999-10-08 07:58:16.000000000 +0200
++++ wmmp3-0.12/wmgeneral.c 2020-05-08 19:16:45.911950119 +0200
+@@ -58,6 +58,11 @@
+ /* X11 Variables */
+ /*****************/
+
++Display *display;
++Window Root, iconwin, win;
++XpmIcon wmgen;
++XpmIcon wmfont;
++
+ int screen;
+ int x_fd;
+ int d_depth;
+diff -Naur wmmp3-0.12.orig/wmgeneral.h wmmp3-0.12/wmgeneral.h
+--- wmmp3-0.12.orig/wmgeneral.h 1999-10-08 07:58:18.000000000 +0200
++++ wmmp3-0.12/wmgeneral.h 2020-05-08 19:16:53.693959618 +0200
+@@ -41,10 +41,10 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
+-Window Root, iconwin, win;
+-XpmIcon wmgen;
+-XpmIcon wmfont;
++extern Display *display;
++extern Window Root, iconwin, win;
++extern XpmIcon wmgen;
++extern XpmIcon wmfont;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmmp3/wmmp3-0.12-r1.ebuild b/x11-plugins/wmmp3/wmmp3-0.12-r1.ebuild
index 23fc74a48c46..ce5131e34556 100644
--- a/x11-plugins/wmmp3/wmmp3-0.12-r1.ebuild
+++ b/x11-plugins/wmmp3/wmmp3-0.12-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,9 @@ DEPEND="${RDEPEND}
media-sound/mpg123
x11-base/xorg-proto"
-PATCHES=( "${FILESDIR}"/${P}-x_includes_n_libraries.patch )
+PATCHES=( "${FILESDIR}"/${P}-x_includes_n_libraries.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ )
DOCS=( AUTHORS ChangeLog sample.wmmp3 README TODO )