summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-17 03:32:16 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-17 04:01:23 -0400
commit8acdbb72f7e48d6ad46c1e27d0b35afd4faede61 (patch)
tree416b152a6e7d956df414521a948db15124d94aa7 /x11-terms/kitty-terminfo
parentx11-terms/kitty-shell-integration: add 0.26.4 (diff)
downloadgentoo-8acdbb72f7e48d6ad46c1e27d0b35afd4faede61.tar.gz
gentoo-8acdbb72f7e48d6ad46c1e27d0b35afd4faede61.tar.bz2
gentoo-8acdbb72f7e48d6ad46c1e27d0b35afd4faede61.zip
x11-terms/kitty-terminfo: add 0.26.4
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.26.4.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index f22c9f20ca38..217a45d5cd1c 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1 +1,2 @@
DIST kitty-0.26.3.tar.xz 4730520 BLAKE2B a2d8cccc76eb295256ac420700e941ac9cb0e79c9717a93226cc30db63ab047dcd0be2e11b36b44c7c15daa0b77a451242d32f71024cee724869ba8937b93dd5 SHA512 77a518cd3ec4bb059907f16d01068914951cadbbcf803dcbfae13cc9ce144f65a886d7e986c7191019a0be9ccf902f086c72a24287458d083cbd3fd136d2c589
+DIST kitty-0.26.4.tar.xz 4749148 BLAKE2B fe15d2bd3afda49fcdc911d0ada5824dffe7eac69cd22581b86f50b0d20330ef10bf567d4adfafe5e06d20f9d7a10c8acfcffb95a3d5c47c50327576d9600761 SHA512 4d3ef5ba2ca54d0f5cd84ece771297c19c05bd276fc235f92c76d469ad17e55b54de696dce38c9039ae9825c7609e03e937536261c4fb680e936865ee0e4441e
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.26.4.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.4.ebuild
new file mode 100644
index 000000000000..e69c32614071
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}