summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-01-15 10:39:45 +0100
committerPacho Ramos <pacho@gentoo.org>2022-01-15 10:40:43 +0100
commit51b066bbdd98bdab54b6a2f4e4a303d9919863dd (patch)
tree45a6d4b000713d5b401b31462b9e219a00968a12 /x11-themes/QGnomePlatform
parentsci-libs/cantera: add Python3.10, update to sci-libs/sundials-5.8 (diff)
downloadgentoo-51b066bbdd98bdab54b6a2f4e4a303d9919863dd.tar.gz
gentoo-51b066bbdd98bdab54b6a2f4e4a303d9919863dd.tar.bz2
gentoo-51b066bbdd98bdab54b6a2f4e4a303d9919863dd.zip
x11-themes/QGnomePlatform: Bump to 0.8.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes/QGnomePlatform')
-rw-r--r--x11-themes/QGnomePlatform/Manifest1
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.8.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/Manifest b/x11-themes/QGnomePlatform/Manifest
index f16acf2d376c..187f4a73decc 100644
--- a/x11-themes/QGnomePlatform/Manifest
+++ b/x11-themes/QGnomePlatform/Manifest
@@ -1,3 +1,4 @@
DIST QGnomePlatform-0.8.0.tar.gz 37381 BLAKE2B 04aeb04f08441aa4964ddb7a3f0b6afbceead82abb5399d36731c77c6de6b303a7db188094857c8346381940deeb8bcd9c6d24e0521cb10b649209e1f6b8d0a0 SHA512 e862b84024ad77976b52cbacf1f920acaa60d2bfcb8f261f1215f2e5fb2dbe6d99e10aa425be70fa2dd324ac4d8c5b85958d68fae4fb7f9728caf097aa1bd102
DIST QGnomePlatform-0.8.1.tar.gz 38565 BLAKE2B 4b581186789990f4a2a7f96a98375185445ef57d8590495323e34875a6a08ca38e8f1e6ece7ff375867c1e126edbe2375e268f722485b29eac914a0139715a16 SHA512 d7b3253b9fcf2a1a6e320d069a6425aa78981a7f19609166b7f53fe1882e19a12fca7326265af091e6335c2ebc1f6492c5262428831e7fd8635ced23439a959f
DIST QGnomePlatform-0.8.3.tar.gz 38556 BLAKE2B 34348bdcd0e5e8d068ba660fa0487e20a495c6584193f69dcd528c892b0259206899de33e833c276ee6b0f1dbb2076b154cdde762f90f5127e9a1156fb8c8627 SHA512 64cba8e01ccb960669f6d9150cfb0f0b03e2371fffb6429fe7b5b6385ab825de6285a98ec27988bf87bb1ce8d61279b0a1fc85a01762aac4b57800f558fa2ff7
+DIST QGnomePlatform-0.8.4.tar.gz 38602 BLAKE2B 19f33ca6fbf43fd5bbd53fec38187802bf0c0d48c4018cff9ae7252e3cca8c8abe27b0aaee54728ad4c232c97efda2163c5a1c1347b1d446f8fa955a0e7709c6 SHA512 e5bb5feae401bca145c4b7a4fc18f5a589e2acba20b9ce7d04a7dd1b1734741daf210ff8fba5e03ef5e4ad07efd274a1279e61b359f319b52e3b9bc4d49f9142
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.8.4.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.8.4.ebuild
new file mode 100644
index 000000000000..1b9fa2ddb7d5
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.8.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtdbus:5=
+ >=dev-qt/qtwidgets-5.15.2:5=
+ dev-qt/qtwayland:5=
+ dev-qt/qtx11extras:5=
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/xdg-desktop-portal
+ x11-libs/gtk+:3[X]
+ >=x11-themes/adwaita-qt-1.4.1
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT6=false
+ )
+ cmake_src_configure
+}