summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-05-14 13:33:27 +0200
committerPacho Ramos <pacho@gentoo.org>2023-05-14 13:37:20 +0200
commit5f7e73ae2db801733d7dcf5f9a70ec12f19e63f5 (patch)
tree03932103d0a8b776c00d5e0383f822049c94a47c /x11-themes/QGnomePlatform
parentmedia-fonts/noto: drop 20201226 (diff)
downloadgentoo-5f7e73ae2db801733d7dcf5f9a70ec12f19e63f5.tar.gz
gentoo-5f7e73ae2db801733d7dcf5f9a70ec12f19e63f5.tar.bz2
gentoo-5f7e73ae2db801733d7dcf5f9a70ec12f19e63f5.zip
x11-themes/QGnomePlatform: add 0.9.1
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes/QGnomePlatform')
-rw-r--r--x11-themes/QGnomePlatform/Manifest1
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.9.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/Manifest b/x11-themes/QGnomePlatform/Manifest
index 005e3ca18dba..e82a2aef98bc 100644
--- a/x11-themes/QGnomePlatform/Manifest
+++ b/x11-themes/QGnomePlatform/Manifest
@@ -1 +1,2 @@
DIST QGnomePlatform-0.9.0.tar.gz 43828 BLAKE2B aa4d1d9269c444d95e7d25e0e0206a63adf0a1be8658624b61d5e5fe55d3714e38a66ecbb6ea19ebf0cc9ee1ed4fb5cf4f29a84e7052c1c2475deca395794cd3 SHA512 7671b0659959ede79e47a821481a14ed861418f364d3d0b48789b1edfcf3b84f2aa658e3afce95730a841fdb018ebad38474a83268bd43b1ccfb653ef7e314aa
+DIST QGnomePlatform-0.9.1.tar.gz 46387 BLAKE2B b62e6c6ca70e7e5a1a611d0a4af022aae0cf4096db51e00b2b45cf6ea655b703cd936336233c71038b82708ec79a202f436f5a29680ada6b4026958604c83670 SHA512 1b8f5d3241bbaa830858dc256285f91023a6e9f664c9920ebfdaf8bdc759e3c958a22bc52eb3559a86d96007118b8ce5efa900167feb491a60232b365c00784c
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.9.1.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.1.ebuild
new file mode 100644
index 000000000000..73a9b14424af
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="wayland"
+
+RDEPEND="
+ dev-qt/qtdbus:5=
+ >=dev-qt/qtquickcontrols2-5.15.2:5=
+ >=dev-qt/qtwidgets-5.15.2:5=
+ wayland? ( dev-qt/qtwayland:5= )
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/xdg-desktop-portal
+ x11-libs/gtk+:3
+ >=x11-themes/adwaita-qt-1.4.2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT6=false
+ -DDISABLE_DECORATION_SUPPORT="$(usex wayland false true)"
+ )
+ cmake_src_configure
+}