summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-24 22:18:08 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-24 22:18:08 +0200
commit626b863c38ecce3cd0f7b1c1c5b7c2cb694e73d2 (patch)
tree03c88766ba60b9f6c52467b207805c0625fd2038 /x11-themes/greybird/greybird-3.18.0.ebuild
parentdev-python/scrapy: Fix typo(s) in USE flag description. (diff)
downloadgentoo-626b863c38ecce3cd0f7b1c1c5b7c2cb694e73d2.tar.gz
gentoo-626b863c38ecce3cd0f7b1c1c5b7c2cb694e73d2.tar.bz2
gentoo-626b863c38ecce3cd0f7b1c1c5b7c2cb694e73d2.zip
x11-themes/greybird: Version bump (bug #589612 by Rustam Karimov).
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-themes/greybird/greybird-3.18.0.ebuild')
-rw-r--r--x11-themes/greybird/greybird-3.18.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-themes/greybird/greybird-3.18.0.ebuild b/x11-themes/greybird/greybird-3.18.0.ebuild
new file mode 100644
index 000000000000..e8790be55552
--- /dev/null
+++ b/x11-themes/greybird/greybird-3.18.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN=${PN/g/G}
+
+DESCRIPTION="The default theme from Xubuntu"
+HOMEPAGE="http://shimmerproject.org/project/greybird/ https://github.com/shimmerproject/Greybird"
+SRC_URI="https://github.com/shimmerproject/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# README says "dual-licensed as GPLv2 or later and CC-BY-SA 3.0 or later"
+LICENSE="CC-BY-SA-3.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+# IUSE="ayatana gnome emerald"
+IUSE="ayatana gnome"
+
+RDEPEND="
+ >=x11-themes/gtk-engines-murrine-0.90
+"
+
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ dodoc README
+ rm -f README LICENSE*
+
+ insinto /usr/share/themes/${MY_PN}-compact/xfwm4
+ doins xfwm4-compact/*
+ rm -rf xfwm4-compact
+
+ insinto /usr/share/themes/${MY_PN}-a11y/xfwm4
+ doins xfwm4-a11y/*
+ rm -rf xfwm4-a11y
+
+ insinto /usr/share/themes/${MY_PN}-bright/xfce-notify-4.0
+ doins xfce-notify-4.0_bright/*
+ rm -rf xfce-notify-4.0_bright
+
+ use ayatana || rm -rf unity
+ use gnome || rm -rf metacity-1
+
+ insinto /usr/share/themes/${MY_PN}
+ doins -r *
+}