summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-19 23:03:39 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-19 23:03:39 +0100
commit5a3dd4af0b3254007a02a4197df65ef819bb6682 (patch)
tree0542aa94872f040bab74100005591ec6f9c36a55 /x11-themes/kfaenza
parentx11-themes/iceicons: update EAPI 6 -> 8 (diff)
downloadgentoo-5a3dd4af0b3254007a02a4197df65ef819bb6682.tar.gz
gentoo-5a3dd4af0b3254007a02a4197df65ef819bb6682.tar.bz2
gentoo-5a3dd4af0b3254007a02a4197df65ef819bb6682.zip
x11-themes/kfaenza: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes/kfaenza')
-rw-r--r--x11-themes/kfaenza/kfaenza-0.8.9-r3.ebuild (renamed from x11-themes/kfaenza/kfaenza-0.8.9-r2.ebuild)27
1 files changed, 14 insertions, 13 deletions
diff --git a/x11-themes/kfaenza/kfaenza-0.8.9-r2.ebuild b/x11-themes/kfaenza/kfaenza-0.8.9-r3.ebuild
index 07f3151900e0..792976c3d5cc 100644
--- a/x11-themes/kfaenza/kfaenza-0.8.9-r2.ebuild
+++ b/x11-themes/kfaenza/kfaenza-0.8.9-r3.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
MY_PN="KFaenza"
+
DESCRIPTION="Faenza-Cupertino icon theme for KDE Plasma"
HOMEPAGE="https://store.kde.org/p/1002580/
https://kde-look.org/content/show.php/KFaenza+icon+patch?content=153813
@@ -12,29 +13,29 @@ HOMEPAGE="https://store.kde.org/p/1002580/
SRC_URI="http://ompldr.org/vYjR0NQ/${P}.tar.gz
http://kde-look.org/CONTENT/content-files/153813-${PN}-icon-patch-0.3.tar.gz
additional? ( http://kde-look.org/CONTENT/content-files/147483-additional-KFaenza.tar.gz )"
+S="${WORKDIR}/${MY_PN}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="+additional branding"
-
-S="${WORKDIR}/${MY_PN}"
RESTRICT="binchecks strip"
src_unpack() {
unpack ${P}.tar.gz
- pushd "${S}" > /dev/null
+ pushd "${S}" >/dev/null || die
+ local tarball
for tarball in ${A}; do
[[ "${tarball}" == ${P}.tar.gz ]] && continue
unpack "${tarball}"
done
- popd > /dev/null
+ popd >/dev/null || die
}
src_prepare() {
default
- # Gentoo bug 620352
+ # Gentoo Bug #620352
local f
for f in 16 22 32 48; do
mv apps/${f}/"numpty physics.png" apps/${f}/"numptyphysics.png" || die
@@ -44,14 +45,14 @@ src_prepare() {
local res
for res in 22 32 48 64 128 256; do
- cp "${S}"/places/${res}/start-here-gentoo.png \
- "${S}"/places/${res}/start-here.png || die
+ cp places/${res}/start-here-gentoo.png \
+ places/${res}/start-here.png || die
done
- cp "${S}"/places/scalable/start-here-gentoo.svg \
- "${S}"/places/scalable/start-here.svg || die
+ cp places/scalable/start-here-gentoo.svg \
+ places/scalable/start-here.svg || die
}
src_install() {
- dodir /usr/share/icons
- cp -R "${S}/" "${D}"/usr/share/icons || die "Install failed!"
+ insinto /usr/share/icons/KFaenza
+ doins -r .
}