summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-09 08:11:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-09 08:30:58 +0200
commit050f97b6afecbe4203fe9b3ca60b5a8bd9577021 (patch)
treedfe246a686bb69410517eba8a80b6803fd7628bf /x11-themes
parentx11-themes/elementary-xfce-icon-theme: Remove old (diff)
downloadgentoo-050f97b6afecbe4203fe9b3ca60b5a8bd9577021.tar.gz
gentoo-050f97b6afecbe4203fe9b3ca60b5a8bd9577021.tar.bz2
gentoo-050f97b6afecbe4203fe9b3ca60b5a8bd9577021.zip
x11-themes/elementary-xfce-icon-theme: Bump to 0.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/elementary-xfce-icon-theme/Manifest1
-rw-r--r--x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.20.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-themes/elementary-xfce-icon-theme/Manifest b/x11-themes/elementary-xfce-icon-theme/Manifest
index 821a59173d8d..318c17c054ca 100644
--- a/x11-themes/elementary-xfce-icon-theme/Manifest
+++ b/x11-themes/elementary-xfce-icon-theme/Manifest
@@ -1 +1,2 @@
DIST elementary-xfce-0.19.tar.gz 7130377 BLAKE2B ee9d94b609fbd1537519f365030996eec2da2f4890380506a5a78ce138ca5174827d0c4ac98850911fe317bfaf64483cbcb06bf40de220493387855eec228a53 SHA512 e36482877e791bdd39a1e0c1e8d5de60865e5845036fb1e5436e62908a4c700adf01b394e5f99ce82abe834aac8dd4d71a17fe4a85de8b50b8a41a2afe3ebbf1
+DIST elementary-xfce-0.20.tar.gz 7439368 BLAKE2B 4413debd94d236177613a701c4040de7577446ecafa73b6162db451b065a3b5a4a689666a1f178a7fd67ccc372624a35724e10a58579e8c2ec396d8a787589dc SHA512 483bd6c7b6ac92f074c79d4b5fe6b992055d6b92a025731d39e1a92f638eb04d38394ed6c38366f4c2eddac8b52e5a605d4e5be69e4a825a02875e5ca31f04d4
diff --git a/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.20.ebuild b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.20.ebuild
new file mode 100644
index 000000000000..34a423a8ea3d
--- /dev/null
+++ b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.20.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg toolchain-funcs
+
+MY_P="${PN%-icon-theme}-${PV}"
+DESCRIPTION="Elementary icons forked from upstream, extended and maintained for Xfce"
+HOMEPAGE="https://github.com/shimmerproject/elementary-xfce"
+SRC_URI="https://github.com/shimmerproject/elementary-xfce/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+# see AUTHORS
+LICENSE="
+ GPL-2+
+ Apache-2.0
+ CC-BY-4.0 CC-BY-NC-SA-4.0 CC-BY-SA-4.0
+ public-domain
+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ media-gfx/optipng
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3"
+
+src_prepare() {
+ sed -i -e 's:-Werror -O0 -pipe:${CFLAGS} ${CPPFLAGS} ${LDFLAGS}:' \
+ svgtopng/Makefile || die
+ # https://dart.dev/brand ; unclear if we should redistribute that
+ find -name application-vnd.dart.svg -delete || die
+ default
+}
+
+src_configure() {
+ # custom script
+ ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ # delete dangling doc links
+ find -L "${D}" -type l -delete || die
+}