summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/jwm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/jwm')
-rw-r--r--x11-wm/jwm/Manifest1
-rw-r--r--x11-wm/jwm/files/jwm-2.0.1-nostrip.patch10
-rw-r--r--x11-wm/jwm/jwm-2.1.0.ebuild70
-rw-r--r--x11-wm/jwm/metadata.xml5
4 files changed, 86 insertions, 0 deletions
diff --git a/x11-wm/jwm/Manifest b/x11-wm/jwm/Manifest
new file mode 100644
index 000000000000..1ba0f399fd1e
--- /dev/null
+++ b/x11-wm/jwm/Manifest
@@ -0,0 +1 @@
+DIST jwm-2.1.0.tar.bz2 163590 SHA256 5c99f9023dc8c2597effdaacc240ff4c2e07e77c8244f3bf1de5cc483bcf08ab
diff --git a/x11-wm/jwm/files/jwm-2.0.1-nostrip.patch b/x11-wm/jwm/files/jwm-2.0.1-nostrip.patch
new file mode 100644
index 000000000000..7b1eb1c7fc83
--- /dev/null
+++ b/x11-wm/jwm/files/jwm-2.0.1-nostrip.patch
@@ -0,0 +1,10 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -20,7 +20,6 @@
+ all: $(EXE)
+
+ install: all
+- strip $(EXE)
+ install -d $(BINDIR)
+ install $(EXE) $(BINDIR)/$(EXE)
+
diff --git a/x11-wm/jwm/jwm-2.1.0.ebuild b/x11-wm/jwm/jwm-2.1.0.ebuild
new file mode 100644
index 000000000000..0118f3d80eff
--- /dev/null
+++ b/x11-wm/jwm/jwm-2.1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Very fast and lightweight still powerful window manager for X"
+HOMEPAGE="http://joewing.net/programs/jwm/"
+SRC_URI="http://joewing.net/programs/jwm/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86 ~x86-fbsd"
+IUSE="bidi debug jpeg png truetype xinerama xpm"
+
+RDEPEND="xpm? ( x11-libs/libXpm )
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ truetype? ( x11-libs/libXft )
+ png? ( media-libs/libpng )
+ jpeg? ( virtual/jpeg )
+ bidi? ( dev-libs/fribidi )
+ dev-libs/expat"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.1-nostrip.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable truetype xft) \
+ $(use_enable xinerama) \
+ $(use_enable xpm) \
+ $(use_enable bidi fribidi) \
+ --enable-shape \
+ --enable-xrender
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /etc
+ dodir /usr/share/man
+ emake BINDIR="${D}/usr/bin" SYSCONF="${D}/etc" \
+ MANDIR="${D}/usr/share/man" install
+ rm "${D}"/etc/system.jwmrc
+
+ echo "#!/bin/sh" > jwm
+ echo "exec /usr/bin/jwm" >> jwm
+ exeinto /etc/X11/Sessions
+ doexe jwm
+
+ dodoc README example.jwmrc todo.txt
+}
+
+pkg_postinst() {
+ einfo "Put an appropriate configuration file in /etc/system.jwmrc"
+ einfo "or in ~/.jwmrc."
+ einfo "An example file can be found in ${EROOT}/usr/share/doc/${PF}/"
+}
diff --git a/x11-wm/jwm/metadata.xml b/x11-wm/jwm/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/x11-wm/jwm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>