summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-21 06:25:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-21 06:25:35 +0200
commit1d5c7c2c6c13fb5b1ec2d8b414596f55f674d459 (patch)
tree4ac9266210e1f424571a62c4ccc32015efb36fbe /xfce-extra/xfce4-mailwatch-plugin
parentdev-python/scikit-build: Bump to 0.17.2 (diff)
downloadgentoo-1d5c7c2c6c13fb5b1ec2d8b414596f55f674d459.tar.gz
gentoo-1d5c7c2c6c13fb5b1ec2d8b414596f55f674d459.tar.bz2
gentoo-1d5c7c2c6c13fb5b1ec2d8b414596f55f674d459.zip
xfce-extra/xfce4-mailwatch-plugin: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-mailwatch-plugin')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/Manifest b/xfce-extra/xfce4-mailwatch-plugin/Manifest
index d4f84ff8ac04..62877d4a3605 100644
--- a/xfce-extra/xfce4-mailwatch-plugin/Manifest
+++ b/xfce-extra/xfce4-mailwatch-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-mailwatch-plugin-1.3.0.tar.bz2 551687 BLAKE2B 3ec841c32df059a2be99ad21c706be794d97c493e9ae1c1be5ec9006c45df51a766c8c89ef9f2941f6c411c18bfd5d01e8a510acfc4233cb349e1528346d0617 SHA512 07d4e4cc2f7d299a142d9e9b307c2797892a5febd8451d5291cb9574be0bd5daba677ee893fea3af49b6a8acbfb827ae0125ba11014df37b6c68a2734ecde11b
+DIST xfce4-mailwatch-plugin-1.3.1.tar.bz2 550836 BLAKE2B c4b53adec738308c37617b3512da8b3dbb6671b934c3ecdca904437b27374af935e92b2eb0d60b91ca42d8c2cb7d336ab687c7fa1d3106872ad368c2d13a3b7d SHA512 cc84c0511fff983283f6af132ff224f62373a1bb608f14b332a75f259f7842491b09f7d9f9d833cb31f81eb392a1b55fe4bf6da8a15b4c62abd2e9640392fb1d
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.1.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.1.ebuild
new file mode 100644
index 000000000000..bbd30e8fffc7
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-mailwatch-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-mailwatch-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="ssl"
+
+DEPEND="
+ >=dev-libs/glib-2.42.0:=
+ >=x11-libs/gtk+-3.22.0:3=
+ >=xfce-base/exo-0.11.0:=
+ >=xfce-base/libxfce4ui-4.14.0:=
+ >=xfce-base/libxfce4util-4.14.0:=
+ >=xfce-base/xfce4-panel-4.14.0:=
+ ssl? ( >=net-libs/gnutls-2:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable ssl)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}