summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/meson-python/Manifest1
-rw-r--r--dev-python/meson-python/files/meson-python-0.7.0-defaults.patch14
-rw-r--r--dev-python/meson-python/meson-python-0.7.0.ebuild45
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index bfaef08c5220..1b3ee629b721 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1 +1,2 @@
DIST meson-python-0.6.0.gh.tar.gz 26783 BLAKE2B d5c5b95d5d609487a0efee1ce05b133794705cdb16f2d05d6e08b9201541e31f61a832c7770b4b5ad675f8dd91860c30c67769ce8fc0af2c48e65b0aad187ddb SHA512 25042ea030d2ad323c67daa0a520db936a4a4efa0de1c9f631c47fac22d797e01d1f1707ed407e2931164a35b3916e19a774ee16ab1d45fc91e41c75add57fa1
+DIST meson-python-0.7.0.gh.tar.gz 28959 BLAKE2B 6b60855d19c7dbbc4c8aca474ad55d4ce2a5db553ba86d2831adea7138d540433733d3b8e4077bf7314a6e6b68cd15b538b336afecaff3b262ae6d2157d8d5f0 SHA512 df529a3d31c67199cf72700734ea62b0de4f8eb03b437af9b53968e37c0350cbe60ba7385f8c3026d66fe2050df4c59912bf65e4a6e62ce19bace52fdcfef2e7
diff --git a/dev-python/meson-python/files/meson-python-0.7.0-defaults.patch b/dev-python/meson-python/files/meson-python-0.7.0-defaults.patch
new file mode 100644
index 000000000000..8a9b4fc21d5a
--- /dev/null
+++ b/dev-python/meson-python/files/meson-python-0.7.0-defaults.patch
@@ -0,0 +1,14 @@
+See https://github.com/FFY00/meson-python/blob/main/mesonpy/__init__.py#L452.
+
+(Also: https://github.com/FFY00/meson-python/issues/54)
+--- a/mesonpy/__init__.py
++++ b/mesonpy/__init__.py
+@@ -532,7 +532,7 @@ class Project():
+ @functools.lru_cache(maxsize=None)
+ def build(self) -> None:
+ """Trigger the Meson build."""
+- self._meson('compile')
++ self._meson('compile', '--verbose')
+ self._meson('install', '--destdir', os.fspath(self._install_dir))
+
+ @classmethod
diff --git a/dev-python/meson-python/meson-python-0.7.0.ebuild b/dev-python/meson-python/meson-python-0.7.0.ebuild
new file mode 100644
index 000000000000..70f7d41728e8
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/FFY00/meson-python/
+"
+SRC_URI="
+ https://github.com/FFY00/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ >=dev-util/meson-0.60.0[${PYTHON_USEDEP}]
+ dev-util/patchelf
+"
+BDEPEND="
+ test? (
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.0-defaults.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest